aboutsummaryrefslogtreecommitdiffstats
path: root/main/dbus
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-19 09:02:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-19 09:02:16 +0000
commite869f125391b49ed53f2a24eac18fa79bae01bc5 (patch)
tree5e279ab3672e5f3ff860662d420085b8b54de8b3 /main/dbus
parentbe7c34e990c471ab21de3b6f218b142181b25809 (diff)
downloadaports-e869f125391b49ed53f2a24eac18fa79bae01bc5.tar.bz2
aports-e869f125391b49ed53f2a24eac18fa79bae01bc5.tar.xz
main/dbus: replace opts in init.d script
ref #943
Diffstat (limited to 'main/dbus')
-rw-r--r--main/dbus/APKBUILD4
-rw-r--r--main/dbus/dbus.initd9
2 files changed, 6 insertions, 7 deletions
diff --git a/main/dbus/APKBUILD b/main/dbus/APKBUILD
index 244a6bd176..81b4c52772 100644
--- a/main/dbus/APKBUILD
+++ b/main/dbus/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dbus
pkgver=1.4.16
-pkgrel=0
+pkgrel=1
pkgdesc="Freedesktop.org message bus system"
url="http://www.freedesktop.org/Software/dbus"
pkggroups="messagebus"
@@ -42,4 +42,4 @@ package() {
install -Dm755 "$srcdir"/dbus.initd "$pkgdir"/etc/init.d/dbus
}
md5sums="44a2a10678e7e50460879c3eb4453a65 dbus-1.4.16.tar.gz
-58356b4db650a89312a670c02804c540 dbus.initd"
+bc835765907698a95da8d8e5bf199378 dbus.initd"
diff --git a/main/dbus/dbus.initd b/main/dbus/dbus.initd
index e96ea05cd1..65271f69c6 100644
--- a/main/dbus/dbus.initd
+++ b/main/dbus/dbus.initd
@@ -1,9 +1,9 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.init-1.0,v 1.4 2007/04/04 13:35:25 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/files/dbus.initd,v 1.1 2011/11/05 13:56:10 ssuominen Exp $
-opts="reload"
+extra_started_commands="reload"
depend() {
need localmount
@@ -12,8 +12,7 @@ depend() {
start() {
ebegin "Starting D-BUS system messagebus"
-
- /usr/bin/dbus-uuidgen --ensure
+ /usr/bin/dbus-uuidgen --ensure=/etc/machine-id
# We need to test if /var/run/dbus exists, since script will fail if it does not
[ ! -e /var/run/dbus ] && mkdir /var/run/dbus