aboutsummaryrefslogtreecommitdiffstats
path: root/main/dhcpcd
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-04-03 16:18:35 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-04-03 16:41:45 +0200
commit4ac514b4b250411f76bb66ef9d79a9d2e7f14225 (patch)
treef1ca4b4df160ff7d29589a013a41e36c4ec80000 /main/dhcpcd
parent767d22bd00c7aac4d3b1b48a4ce864b65bdccfc2 (diff)
downloadaports-4ac514b4b250411f76bb66ef9d79a9d2e7f14225.tar.bz2
aports-4ac514b4b250411f76bb66ef9d79a9d2e7f14225.tar.xz
main/dhcpcd: improve runscript, fix code-style
Diffstat (limited to 'main/dhcpcd')
-rw-r--r--main/dhcpcd/APKBUILD2
-rw-r--r--main/dhcpcd/dhcpcd.initd11
2 files changed, 5 insertions, 8 deletions
diff --git a/main/dhcpcd/APKBUILD b/main/dhcpcd/APKBUILD
index 0374c8cdaa..0e96adf414 100644
--- a/main/dhcpcd/APKBUILD
+++ b/main/dhcpcd/APKBUILD
@@ -53,4 +53,4 @@ package() {
sha512sums="f5b1407199163fb994519bc1b5a70ad043f00f263e3b254da5d519d1c6b689a4a5a8bcef3bf42401826984e273c2ead38249fcfe99129b87034f90de2fc46ecd dhcpcd-7.0.2.tar.xz
692b2c8c75166fabd512a7cc69c650f9391e0f682ce9cbe1771bfa44e82dcf09e322c46493c45ca75000f479d3cddde306754ba31d28a798a15e2b79a56045f0 busybox-logger.patch
1c19eed0f7a008ee96ea392beb327169ff8c83fc27fed20f65f05c9125f60629ebe3474c5e6a7cf4aeeea448fde4264c9b84916efacd67d47ab908c47b1fc3a5 fix-chrony-conf-location.patch
-6d3220155f2d9ed3e3a00afd378eeb70d435e19804201f8bb35498f1f7f3dfdaeaa2f4a01a18f5e96b457d9c173bc6a206b3e67ebf6d95da7e7b350dcd153fde dhcpcd.initd"
+e777432c2efc84285b41e63a4687f3bd543f6864218d037529ab78b5ad934de154f28f478bd9facb56628f2953aad8a932bc2eb8b1dfffa0ce2278ffcfc4d880 dhcpcd.initd"
diff --git a/main/dhcpcd/dhcpcd.initd b/main/dhcpcd/dhcpcd.initd
index d3f4d76b4c..0539b25daf 100644
--- a/main/dhcpcd/dhcpcd.initd
+++ b/main/dhcpcd/dhcpcd.initd
@@ -1,14 +1,11 @@
#!/sbin/openrc-run
-# Copyright 2007-2008 Roy Marples <roy@marples.name>
-# All rights reserved. Released under the 2-clause BSD license.
-command=/sbin/dhcpcd
-pidfile=/var/run/dhcpcd.pid
-command_args=-q
name="DHCP Client Daemon"
+command="/sbin/dhcpcd"
+pidfile="/run/dhcpcd.pid"
+command_args="-q ${command_args:-}"
-depend()
-{
+depend() {
provide net
need localmount
use logger network