aboutsummaryrefslogtreecommitdiffstats
path: root/main/duplicity
diff options
context:
space:
mode:
authorMatt Smith <mcs@darkregion.net>2011-03-29 23:38:12 -0500
committerMatt Smith <mcs@darkregion.net>2011-03-29 23:38:12 -0500
commit168bc56a766049485faf3805b48d42fbf4145a8c (patch)
tree13ccc656146327ecd9d98d19a4b50b4ea0022718 /main/duplicity
parente42b1c768430e7ca23097d9473d7c6efb21962a7 (diff)
downloadaports-168bc56a766049485faf3805b48d42fbf4145a8c.tar.bz2
aports-168bc56a766049485faf3805b48d42fbf4145a8c.tar.xz
main/duplicity: moved from testing
Diffstat (limited to 'main/duplicity')
-rw-r--r--main/duplicity/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/main/duplicity/APKBUILD b/main/duplicity/APKBUILD
new file mode 100644
index 0000000000..2562ee2d40
--- /dev/null
+++ b/main/duplicity/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Matt Smith <mcs@darkregion.net>
+# Maintainer: Matt Smith <mcs@darkregion.net>
+pkgname=duplicity
+pkgver=0.6.12
+pkgrel=0
+pkgdesc="Encrypted bandwidth-efficient backup using the rsync algorithm"
+url="http://duplicity.nongnu.org/"
+arch="all"
+license="GPL"
+depends="python py-boto ncftp librsync gnupg"
+makedepends="wget python-dev py-setuptools librsync-dev"
+install=
+subpackages="$pkgname-doc"
+source="https://code.launchpad.net/$pkgname/${pkgver:0:3}-series/$pkgver/+download/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root "$pkgdir"
+}
+
+md5sums="9b84c984054550bbb2ba29b553567b7b duplicity-0.6.12.tar.gz"