aboutsummaryrefslogtreecommitdiffstats
path: root/main/enchant
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-09-06 19:30:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-09-06 19:30:55 +0000
commite8810f4ae37e7d286d1dedf7fec46bc19bf50119 (patch)
treed35b7a4ace927374b4b525cec33d3833df1dd85a /main/enchant
parentc27a88b02c0cc1ab4fb9e924cd98f4149ec4d488 (diff)
downloadaports-e8810f4ae37e7d286d1dedf7fec46bc19bf50119.tar.bz2
aports-e8810f4ae37e7d286d1dedf7fec46bc19bf50119.tar.xz
main/enchant: fix build with hunspell 1.4
Diffstat (limited to 'main/enchant')
-rw-r--r--main/enchant/APKBUILD23
-rw-r--r--main/enchant/hunspell-build-fix.patch14
2 files changed, 28 insertions, 9 deletions
diff --git a/main/enchant/APKBUILD b/main/enchant/APKBUILD
index 72b8cedd92..ed38cd3375 100644
--- a/main/enchant/APKBUILD
+++ b/main/enchant/APKBUILD
@@ -9,17 +9,19 @@ license="LGPL2+"
subpackages="$pkgname-dev $pkgname-doc"
depends=""
depends_dev="glib-dev"
-makedepends="aspell-dev dbus-glib-dev hunspell-dev gettext-dev"
-source="http://www.abisource.com/downloads/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
+makedepends="aspell-dev dbus-glib-dev hunspell-dev gettext-dev file bash"
+source="http://www.abisource.com/downloads/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
+ hunspell-build-fix.patch"
-_builddir="$srcdir/$pkgname-$pkgver"
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- cd "$_builddir"
+ cd "$builddir"
update_config_sub || return 1
+ default_prepare
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,9 +32,12 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="de11011aff801dc61042828041fb59c7 enchant-1.6.0.tar.gz"
-sha256sums="2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03f7097f enchant-1.6.0.tar.gz"
-sha512sums="0ca1634bb783df51512df4abecc89abdadee6baf7330d6e5f90cc15d10779896a3521a1c079ecc07e4df4f7a018ce398cca9d0125a7845a314a059840ebc9137 enchant-1.6.0.tar.gz"
+md5sums="de11011aff801dc61042828041fb59c7 enchant-1.6.0.tar.gz
+1305a6c285b5970bb1ef0f033f49f329 hunspell-build-fix.patch"
+sha256sums="2fac9e7be7e9424b2c5570d8affe568db39f7572c10ed48d4e13cddf03f7097f enchant-1.6.0.tar.gz
+54e325f71959828f1f04e03cd33b9b80f0dfdc89b68859c08e51831052f1b346 hunspell-build-fix.patch"
+sha512sums="0ca1634bb783df51512df4abecc89abdadee6baf7330d6e5f90cc15d10779896a3521a1c079ecc07e4df4f7a018ce398cca9d0125a7845a314a059840ebc9137 enchant-1.6.0.tar.gz
+c0b7fd8fd00a81ea2c08ea7ce2bdffa826b5a3a0c06eacb818681f0f977d8e76c69f7938c10cdf71571cd1cbbf0e576d36fc74a41755fb570e047525195aeb99 hunspell-build-fix.patch"
diff --git a/main/enchant/hunspell-build-fix.patch b/main/enchant/hunspell-build-fix.patch
new file mode 100644
index 0000000000..0ecdb24b30
--- /dev/null
+++ b/main/enchant/hunspell-build-fix.patch
@@ -0,0 +1,14 @@
+diff -ru enchant-1.6.0-orig/src/myspell/myspell_checker.cpp enchant-1.6.0/src/myspell/myspell_checker.cpp
+--- enchant-1.6.0-orig/src/myspell/myspell_checker.cpp 2016-04-18 12:25:00.094614256 +0100
++++ enchant-1.6.0/src/myspell/myspell_checker.cpp 2016-04-18 12:26:09.108569576 +0100
+@@ -148,6 +148,10 @@
+ g_iconv_close(m_translate_out);
+ }
+
++#ifndef MAXWORDLEN
++# define MAXWORDLEN 100
++#endif
++
+ bool
+ MySpellChecker::checkWord(const char *utf8Word, size_t len)
+ {