aboutsummaryrefslogtreecommitdiffstats
path: root/main/espeak
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-22 14:51:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-22 14:51:02 +0000
commit4c465ebf03fd9183ae0eb91620cd80984c138c07 (patch)
treec83ab97f7a7bfc7e2289b29a9d6ce3b8ebc13638 /main/espeak
parent8a1ef73be694bbe20235afcceec6877e5da13cc7 (diff)
downloadaports-4c465ebf03fd9183ae0eb91620cd80984c138c07.tar.bz2
aports-4c465ebf03fd9183ae0eb91620cd80984c138c07.tar.xz
main/espeak: upgrade to 1.42.04
Diffstat (limited to 'main/espeak')
-rw-r--r--main/espeak/APKBUILD43
-rw-r--r--main/espeak/espeak-1.40.02-uclibc++.patch21
2 files changed, 13 insertions, 51 deletions
diff --git a/main/espeak/APKBUILD b/main/espeak/APKBUILD
index bf005e00a5..c31ce3818a 100644
--- a/main/espeak/APKBUILD
+++ b/main/espeak/APKBUILD
@@ -1,42 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=espeak
-pkgver=1.40.02
+pkgver=1.42.04
pkgrel=0
pkgdesc="Speech synthesizer for English and other languages"
url="http://espeak.sourceforge.net/"
license="GPL-3"
subpackages="$pkgname-dev"
-depends="uclibc uclibc++"
-makedepends="uclibc++-dev"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-source.zip
- $pkgname-$pkgver-uclibc++.patch"
+depends=
+makedepends=
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver-source.zip"
-build() {
- local s="$srcdir"/$pkgname-$pkgver-source
- cd "$s"
- for i in ../*.patch; do
- msg "Applying $i..."
- patch -p1 < $i || return 1
- done
-
- export CXX=g++-uc
-
- cd src
- make CXXFLAGS="${CXXFLAGS}" AUDIO=none all || return 1
+_builddir="$srcdir"/$pkgname-$pkgver-source
- msg "Fixing byte order of phoneme data files"
- cd "$s"/platforms/big_endian
- make
- ./espeak-phoneme-data "$s"/espeak-data
- cp -f phondata phonindex phontab "$s"/espeak-data
-
- cd "$s"/src
- make DESTDIR="$pkgdir" AUDIO=none install || return 1
+build() {
+ cd "$_builddir"/src
+ make AUDIO=none || return 1
+}
- cd "$s"
- install -d "$pkgdir"/usr/share/espeak-data
- cp -r dictsource "$pkgdir"/usr/share/espeak-data
+package() {
+ cd "$_builddir"/src
+ make AUDIO=none DESTDIR="$pkgdir" install || return 1
}
-md5sums="708954b44c526e8174df8b88a6382738 espeak-1.40.02-source.zip
-c13bb95088c5777b4d3e5ea10ca37517 espeak-1.40.02-uclibc++.patch"
+md5sums="a4cbbe5f2e2a37ccc0aa1a687a6e4c11 espeak-1.42.04-source.zip"
diff --git a/main/espeak/espeak-1.40.02-uclibc++.patch b/main/espeak/espeak-1.40.02-uclibc++.patch
deleted file mode 100644
index 6899220525..0000000000
--- a/main/espeak/espeak-1.40.02-uclibc++.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- espeak-1.40.02-source.orig/src/Makefile 2008-12-26 10:11:49 +0000
-+++ espeak-1.40.02-source/src/Makefile 2008-12-26 10:27:48 +0000
-@@ -60,15 +60,15 @@
-
- SRCS1=$(speak_SOURCES)
- OBJS1=$(patsubst %.cpp,%.o,$(SRCS1))
--LIBS1=-lstdc++ $(LIB_AUDIO) -lpthread $(EXTRA_LIBS)
-+LIBS1=-lm $(LIB_AUDIO) -lpthread $(EXTRA_LIBS)
-
- SRCS2=$(libespeak_SOURCES)
- OBJS2=$(patsubst %.cpp,x_%.o,$(SRCS2))
--LIBS2=-lstdc++ $(LIB_AUDIO) -lpthread
-+LIBS2=-lm $(LIB_AUDIO) -lpthread
-
- SRCS3 = espeak.cpp
- OBJS3=$(patsubst %.cpp,%.o,$(SRCS3))
--LIBS3=-lstdc++ -L . -lespeak
-+LIBS3=-L . -lespeak -lpthread
-
- CXXFLAGS=-O2
-