aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeradius
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-08-06 12:03:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-08-06 12:04:36 +0000
commit8be40b15b63d279a0f1ce78e612e1f407dffcbe6 (patch)
tree933c71b10239a0e58574b16320de174fa4fd2d03 /main/freeradius
parentd2d2b27323141a4cf039647fe1c6d632557a5967 (diff)
downloadaports-8be40b15b63d279a0f1ce78e612e1f407dffcbe6.tar.bz2
aports-8be40b15b63d279a0f1ce78e612e1f407dffcbe6.tar.xz
main/freeradius: add json support to rest module
it needs an ugly hack to find the header ref #4511
Diffstat (limited to 'main/freeradius')
-rw-r--r--main/freeradius/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/main/freeradius/APKBUILD b/main/freeradius/APKBUILD
index c05215d454..6c91113b88 100644
--- a/main/freeradius/APKBUILD
+++ b/main/freeradius/APKBUILD
@@ -5,7 +5,7 @@
pkgname=freeradius
_realname=freeradius
pkgver=3.0.9
-pkgrel=0
+pkgrel=1
pkgdesc="RADIUS (Remote Authentication Dial-In User Service) server"
url="http://freeradius.org/"
arch="all"
@@ -14,7 +14,7 @@ depends=""
makedepends="openssl-dev mariadb-dev postgresql-dev gdbm-dev readline-dev
bash libtool autoconf automake perl-dev python-dev openldap-dev krb5-dev
unixodbc-dev linux-pam-dev sqlite-dev talloc-dev libpcap-dev
- linux-headers curl-dev hiredis-dev"
+ linux-headers curl-dev hiredis-dev json-c-dev"
pkggroups="radius"
pkgusers="radius"
install="$pkgname.pre-install"
@@ -58,6 +58,10 @@ prepare() {
build() {
cd "$_builddir"
+ # freeradius requries json.h to be in a dir called 'json'. We fool
+ # the configure script with a symlink pointing to proper location.
+ ln -s /usr/include/json-c json
+
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -87,6 +91,7 @@ build() {
--without-rlm_sql_oracle \
--without-rlm_yubikey \
--without-rlm_ykclient \
+ --with-jsonc-include-dir="$PWD" \
|| return 1
make -j1 LDFLAGS="$LDFLAGS -lssl" || return 1