aboutsummaryrefslogtreecommitdiffstats
path: root/main/freeswitch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-11-16 08:27:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-11-16 09:02:50 +0000
commit8b0e75ff1f56d9dcc07af9efe47e8f3c7aef0f56 (patch)
tree44a4bd29f40a77f83878a45f8c6f6c9996957d6c /main/freeswitch
parenta398fd6b60959e4f15876176f43a472bec54772f (diff)
downloadaports-8b0e75ff1f56d9dcc07af9efe47e8f3c7aef0f56.tar.bz2
aports-8b0e75ff1f56d9dcc07af9efe47e8f3c7aef0f56.tar.xz
main/freeswitch: build fix for x86
Diffstat (limited to 'main/freeswitch')
-rw-r--r--main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch39
-rw-r--r--main/freeswitch/APKBUILD6
2 files changed, 44 insertions, 1 deletions
diff --git a/main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch b/main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
new file mode 100644
index 0000000000..f11c2d1657
--- /dev/null
+++ b/main/freeswitch/0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
@@ -0,0 +1,39 @@
+From de06bf086bdaa442cba0d44bde65265eb4d7fc14 Mon Sep 17 00:00:00 2001
+From: Stanislav Sinyagin <ssinyagin@k-open.com>
+Date: Mon, 9 Nov 2015 21:54:00 +0000
+Subject: [PATCH] FS-8427 Incompatible type for %ld in prinrtf
+
+---
+ src/mod/applications/mod_av/avcodec.c | 2 +-
+ src/mod/endpoints/mod_rtmp/rtmp_tcp.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/mod/applications/mod_av/avcodec.c b/src/mod/applications/mod_av/avcodec.c
+index 4d4cb24..199f760 100644
+--- a/src/mod/applications/mod_av/avcodec.c
++++ b/src/mod/applications/mod_av/avcodec.c
+@@ -539,7 +539,7 @@ static void fs_rtp_parse_h263_rfc2190(h264_codec_context_t *context, AVPacket *p
+ mb_info_pos++;
+ } else {
+ switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_WARNING,
+- "Unable to split H263 packet! mb_info_pos=%d mb_info_count=%d pos=%d max=%ld\n", mb_info_pos, mb_info_count, pos, end - buf_base);
++ "Unable to split H263 packet! mb_info_pos=%d mb_info_count=%d pos=%d max=%"SWITCH_SIZE_T_FMT"\n", mb_info_pos, mb_info_count, pos, (switch_size_t)(end - buf_base));
+ }
+ } else {
+ switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_ERROR, "Should Not Happen!!! mb_info_pos=%d mb_info_count=%d mb_info_size=%d\n", mb_info_pos, mb_info_count, mb_info_size);
+diff --git a/src/mod/endpoints/mod_rtmp/rtmp_tcp.c b/src/mod/endpoints/mod_rtmp/rtmp_tcp.c
+index e716272..4389cef 100644
+--- a/src/mod/endpoints/mod_rtmp/rtmp_tcp.c
++++ b/src/mod/endpoints/mod_rtmp/rtmp_tcp.c
+@@ -136,7 +136,7 @@ again:
+ break;
+ }
+
+- if (*len != orig_len) switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_INFO, "sent %ld of %ld\n", *len, orig_len);
++ if (*len != orig_len) switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_INFO, "sent %"SWITCH_SIZE_T_FMT" of %"SWITCH_SIZE_T_FMT"\n", *len, orig_len);
+ buf += *len;
+ remaining -= *len;
+ *len = remaining;
+--
+2.6.3
+
diff --git a/main/freeswitch/APKBUILD b/main/freeswitch/APKBUILD
index 307c21d19f..85ec4ea1b3 100644
--- a/main/freeswitch/APKBUILD
+++ b/main/freeswitch/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Cameron Banta <cbanta@gmail.com>
pkgname=freeswitch
pkgver=1.6.2
-pkgrel=0
+pkgrel=1
pkgdesc="A communications platform written in C from the ground up"
url="http://www.freeswitch.org"
arch="all"
@@ -64,6 +64,7 @@ _libsources="
source="http://files.freeswitch.org/freeswitch-releases/$pkgname-$pkgver.tar.xz
$_libsources
+ 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
getlib.patch
modules.conf
freeswitch.confd
@@ -202,16 +203,19 @@ conf() {
}
md5sums="6e7fbf77be0fcccecf12284437e6cbda freeswitch-1.6.2.tar.xz
+80d7f0aa84278f5236805753ec3e3f1f 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
1e7f335ee00f589825ecc9affa779346 getlib.patch
d67ac9b54cc062ffff7c2b4d5631c3bd modules.conf
c608cca8ad773acebf201f581438c7e7 freeswitch.confd
3b0bf4847a61afa28229b58763f4c400 freeswitch.initd"
sha256sums="cf26f491469d2f744fb48ba0a7e25cefd96305e0ef385eda09fca82c096bb48f freeswitch-1.6.2.tar.xz
+cc8e509c7aab120eb74a23b2c2a8c64e00497377ea9fc5572559c3361ddfefec 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
ab437c92149b6fc88bc2fc8a228d6a5f8af574e2c90469a6dc4c753d13972c34 getlib.patch
12084b329ed10b109fe1487e9a4e378dea8c0d85a6ff9c3533245b37019e5af3 modules.conf
846a29a361ef6eecd77876963b5c0133699c40fa8b34c68df42d5f8a1a1915b1 freeswitch.confd
aa0d89221ffa47eba4a0e085f6041ee198476409dd15d1e90c5c357ba683f432 freeswitch.initd"
sha512sums="b85ebbdc0f4111f76e798b91d23d05b63966fe8ac273bc2581857c1b9b810f970f25fd244ce40884d4939e835c72d7700448ea663a4f2650eb34d67325aa0517 freeswitch-1.6.2.tar.xz
+5faaf44f36430ad18769b36e45571320a139e853f6adec2ed0f2c16fffdcd0461a30a674dbae18edc0701a5c1e76f5ddb30962960421db6b103e2f220b9482d0 0001-FS-8427-Incompatible-type-for-ld-in-prinrtf.patch
4ceb48f64d2bc26a02cc0846276506241bfd30c156422b0a1d608fd172c099feb5c121a763652e9a45046dcdd0ba0eb71eab240e0c6ce2ad63ff781719e135a4 getlib.patch
89faf3a64797b339f2f03ed8bf3e02a17c03896e6c0ca6dbb710a8d7f42ad06299bc5975add6bfd9d038c2aa76239a2f5d83530e8346d24d8f6716fc2fe36c66 modules.conf
a585f6411185a26206137a1ad97a06fd6c73e80c5439e9be45eabfa70e7a83120169ba882971fcd328436c8e0242cbd664170b80754ea2846021689baf1f1595 freeswitch.confd