aboutsummaryrefslogtreecommitdiffstats
path: root/main/fts
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-12-17 00:30:00 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-17 00:30:00 -0600
commit01907687add4bd2c41053f1314ad423d6c9c21fe (patch)
treee0611b97295c3fb7ef4f78a98b3bef6cd7896a32 /main/fts
parente619a482fcbd7421c0130a06b3aa1700e3ef86f6 (diff)
downloadaports-01907687add4bd2c41053f1314ad423d6c9c21fe.tar.bz2
aports-01907687add4bd2c41053f1314ad423d6c9c21fe.tar.xz
main/fts: *plonk*
Diffstat (limited to 'main/fts')
-rw-r--r--main/fts/APKBUILD56
-rw-r--r--main/fts/fts-header-correctness.patch20
-rw-r--r--main/fts/fts-uclibc.patch45
-rw-r--r--main/fts/stdint.patch10
4 files changed, 0 insertions, 131 deletions
diff --git a/main/fts/APKBUILD b/main/fts/APKBUILD
deleted file mode 100644
index e6f2850ec7..0000000000
--- a/main/fts/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor: William Pitcock <nenolod@dereferenced.org>
-# Maintainer: William Pitcock <nenolod@dereferenced.org>
-pkgname=fts
-pkgver=0
-pkgrel=3
-pkgdesc="keith bostic's POSIX file tree stream operations library"
-url="http://bostic.com/"
-arch="all"
-license="BSD"
-depends=
-depends_dev=
-makedepends="$depends_dev wget"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-replaces_doc="man-pages"
-source="saveas-https://sites.google.com/a/bostic.com/keithbostic/files/fts.tar.gz?attredirects=0/fts.tar.gz
- fts-uclibc.patch
- fts-header-correctness.patch
- stdint.patch"
-
-_builddir="${srcdir}/${pkgname}"
-prepare() {
- local i
- cd "$_builddir"
- chmod +w *.c
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- gcc -I. -fPIC -shared -o libfts.so -Wl,-soname,libfts.so.${pkgver} fts.c
-}
-
-package() {
- cd "$_builddir"
-
- install -d "$pkgdir"/usr/lib
-
- install -m 755 libfts.so "$pkgdir"/usr/lib/libfts.so.${pkgver}
- ln -sf libfts.so.${pkgver} "$pkgdir"/usr/lib/libfts.so
-
- install -d "$pkgdir"/usr/include
- install -m 644 fts.h "$pkgdir"/usr/include/fts.h
-
- install -d "$pkgdir"/usr/share/man/man3
- install -m 644 fts.3 "$pkgdir"/usr/share/man/man3/fts.3
-}
-
-md5sums="120c14715485ec6ced14f494d059d20a fts.tar.gz
-588fead4044bf535ff97298651aaab8f fts-uclibc.patch
-b197744ece4ef9a5fa52692acf9b6666 fts-header-correctness.patch
-a8a5a8e81e1c67738aef00f3f13a718b stdint.patch"
diff --git a/main/fts/fts-header-correctness.patch b/main/fts/fts-header-correctness.patch
deleted file mode 100644
index 59061bfc95..0000000000
--- a/main/fts/fts-header-correctness.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- fts.orig/fts.h
-+++ fts/fts.h
-@@ -38,6 +38,17 @@
- #ifndef _FTS_H_
- #define _FTS_H_
-
-+#include <sys/types.h>
-+#include <sys/param.h>
-+#include <sys/stat.h>
-+
-+#include <dirent.h>
-+#include <errno.h>
-+#include <fcntl.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <unistd.h>
-+
- typedef struct {
- struct _ftsent *fts_cur; /* current node */
- struct _ftsent *fts_child; /* linked list of children */
diff --git a/main/fts/fts-uclibc.patch b/main/fts/fts-uclibc.patch
deleted file mode 100644
index 3593530396..0000000000
--- a/main/fts/fts-uclibc.patch
+++ /dev/null
@@ -1,45 +0,0 @@
---- fts.orig/fts.c
-+++ fts/fts.c
-@@ -31,6 +31,10 @@
- * SUCH DAMAGE.
- */
-
-+#define alignof(TYPE) ((int) &((struct { char dummy1; TYPE dummy2; } *) 0)->dummy2)
-+#define ALIGNBYTES (alignof(long double) - 1)
-+#define ALIGN(p) (((uintptr_t)(p) + ALIGNBYTES) & ~ALIGNBYTES)
-+
- #if defined(LIBC_SCCS) && !defined(lint)
- static char sccsid[] = "@(#)fts.c 8.6 (Berkeley) 8/14/94";
- #endif /* LIBC_SCCS and not lint */
-@@ -652,10 +656,10 @@
- if (!ISSET(FTS_SEEDOT) && ISDOT(dp->d_name))
- continue;
-
-- if ((p = fts_alloc(sp, dp->d_name, (int)dp->d_namlen)) == NULL)
-+ if ((p = fts_alloc(sp, dp->d_name, (int)dp->d_reclen)) == NULL)
- goto mem1;
-- if (dp->d_namlen > maxlen) {
-- if (fts_palloc(sp, (size_t)dp->d_namlen)) {
-+ if (dp->d_reclen > maxlen) {
-+ if (fts_palloc(sp, (size_t)dp->d_reclen)) {
- /*
- * No more memory for path or structures. Save
- * errno, free up the current structure and the
-@@ -675,7 +679,7 @@
- maxlen = sp->fts_pathlen - sp->fts_cur->fts_pathlen - 1;
- }
-
-- p->fts_pathlen = len + dp->d_namlen + 1;
-+ p->fts_pathlen = len + dp->d_reclen + 1;
- p->fts_parent = sp->fts_cur;
- p->fts_level = level;
-
-@@ -784,7 +788,7 @@
- /* If user needs stat info, stat buffer already allocated. */
- sbp = ISSET(FTS_NOSTAT) ? &sb : p->fts_statp;
-
--#ifdef DT_WHT
-+#ifdef S_IFWHT
- /*
- * Whited-out files don't really exist. However, there's stat(2) file
- * mask for them, so we set it so that programs (i.e., find) don't have
diff --git a/main/fts/stdint.patch b/main/fts/stdint.patch
deleted file mode 100644
index 1ad7157e58..0000000000
--- a/main/fts/stdint.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./fts.c.orig
-+++ ./fts.c
-@@ -46,6 +46,7 @@
- #include <errno.h>
- #include <fcntl.h>
- #include <fts.h>
-+#include <stdint.h>
- #include <stdlib.h>
- #include <string.h>
- #include <unistd.h>