aboutsummaryrefslogtreecommitdiffstats
path: root/main/fuse3
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-09-04 15:19:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-04 15:28:09 +0000
commit165ba7eebbe3ff10a4fa7fd599f06de7802043f9 (patch)
tree5a831e5e03b999e064d40d55b7c8b2396f349504 /main/fuse3
parent0701a252c50177563e2c1a13d9d1fe2e8a6e0d0d (diff)
downloadaports-165ba7eebbe3ff10a4fa7fd599f06de7802043f9.tar.bz2
aports-165ba7eebbe3ff10a4fa7fd599f06de7802043f9.tar.xz
main/fuse(3): fix conflict
make a fuse-common and fuse-openrc package so fuse(2) and fuse(3) no longer conflict.
Diffstat (limited to 'main/fuse3')
-rw-r--r--main/fuse3/APKBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/main/fuse3/APKBUILD b/main/fuse3/APKBUILD
index 31fedd8206..3e761301a3 100644
--- a/main/fuse3/APKBUILD
+++ b/main/fuse3/APKBUILD
@@ -7,15 +7,15 @@ pkgdesc="The reference implementation of the Linux FUSE (Filesystem in Userspace
url="https://github.com/libfuse/libfuse"
arch="all"
license="GPL-2.0-only LGPL-2.1-only"
-depends="!fuse"
+depends="fuse-common"
makedepends="gettext-dev linux-headers meson eudev-dev python3
py3-six py3-pluggy py3-attrs py3-py"
checkdepends="py3-pytest"
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc fuse-common:_common fuse-openrc:_openrc"
source="https://github.com/libfuse/libfuse/releases/download/fuse-$pkgver/fuse-$pkgver.tar.xz
fix-realpath.patch
fuse.initd"
-options="suid"
+options="suid !check" # check is currently broken: https://github.com/libfuse/libfuse/issues/293
builddir="$srcdir"/$_pkgname-$pkgver
@@ -59,7 +59,17 @@ package() {
#
#user_allow_other
_EOF_
+}
+
+_common() {
+ pkgdesc="Common files for fuse2 and fuse3"
+ mkdir -p "$subpkgdir"/etc/
+ mv "$pkgdir"/etc/fuse.conf "$subpkgdir"
+}
+_openrc() {
+ default_openrc
+ install_if="openrc fuse-common=$pkgver-r$pkgrel"
}
sha512sums="90c56a6652967450f03cb0f20ae929091a3e8b3f6927fe7a6ce59bb5e3f247d34a44ce19f085ab09547d9cc38ab1cec1e71fe44ec5c4f201782150aadcbe6b4f fuse-3.2.5.tar.xz