aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-06 12:53:36 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 13:45:01 +0000
commit0415ebf6f9e5bae8338a45cc147f1b8536ef45d7 (patch)
treef6c392e458c69ee39d342033ad1e3043f42d3279 /main/gcc
parente6b4a901e9b25cd664d56c16fcc1e410a2e4a53d (diff)
downloadaports-0415ebf6f9e5bae8338a45cc147f1b8536ef45d7.tar.bz2
aports-0415ebf6f9e5bae8338a45cc147f1b8536ef45d7.tar.xz
main/gcc: more cross-build fixes
- remove !tracedeps; errors will be shown during packaging but they are safe to ignore. tracedeps is needed for proper so provides to be generated - fix shared libada building when cross-compiling native compiler
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD5
-rw-r--r--main/gcc/libada-cross-shared.patch22
2 files changed, 26 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 245d169a32..edb9bffc28 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -19,7 +19,6 @@ makedepends_build="paxmark bison flex texinfo gawk zip gmp-dev mpfr-dev mpc1-dev
makedepends_host="linux-headers gmp-dev mpfr-dev mpc1-dev zlib-dev !gettext-dev"
makedepends="$makedepends_build $makedepends_host"
subpackages=" "
-[ "$_cross" ] && options="!tracedeps"
[ "$CHOST" = "$CTARGET" ] && subpackages="gcc-doc$_cross"
replaces="libstdc++ binutils"
@@ -168,6 +167,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.bz2
207-static-pie.patch
libgcc-always-build-gcceh.a.patch
+ libada-cross-shared.patch
gcc-4.9-musl-fortify.patch
gcc-6.1-musl-libssp.patch
boehm-gc-musl.patch
@@ -634,6 +634,7 @@ feaddd681acded33c22fd92ad8819982 204-linux_libc_has_function.patch
a7836fe20d35f91ddf623e3c62a920fe 205-nopie.patch
0b0a4f54760e0e368e4113dc9bd04d7b 207-static-pie.patch
504c7dd8651c5d98229892c4cd9ea591 libgcc-always-build-gcceh.a.patch
+a56fb2cf67ae619f22e0d21f378ff704 libada-cross-shared.patch
9e658e590bc51be611f39945183f6aa2 gcc-4.9-musl-fortify.patch
32c40cd9c22a01621c2b7d60ac4255a0 gcc-6.1-musl-libssp.patch
0ea0f556d4ef9c260d1353b7fd33970c boehm-gc-musl.patch
@@ -670,6 +671,7 @@ a5de063de487d944443901cdfa398e1614edbf2e62b7d633f78da1be222a2b05 202-posix_mema
2427b5a0e564af84c6569921a31a277d07b739a4a4d924057ce725136cc5d355 205-nopie.patch
df92e2f03615c1591278c132cd38ee0ed2c576cd942d8ea751a44d0521057e6b 207-static-pie.patch
1975189156d70f5428cb7f1516533965d1c8734f3009fc89a9b8e289b72326f1 libgcc-always-build-gcceh.a.patch
+b07b999e3d3fdeff6aa925535949cb90bc7b11546b415288e5097c8877e5e8d1 libada-cross-shared.patch
dc93f97dff28b872f9c7e241fb87a3eca0271f706534d196b3517781b05667fa gcc-4.9-musl-fortify.patch
4ece19529edb8e681e1778e977e2ba1d47984ccfcb82505e8b898bb29d659625 gcc-6.1-musl-libssp.patch
6ccca88695ef84c0d038cd315cad5ae5b799672ecb009fdaab34e68ba60b733c boehm-gc-musl.patch
@@ -706,6 +708,7 @@ fc0de05b36613b732a0222ea005c90653c6a40d6761b6894af2419272f4e74875f37e26af33a9b99
98473bcaa77903a223ca9b0d2087c0921b287a2816d308cc32c8fe009e6cbf5dd1ae7fba27794ab8d9c09e117fe534413d91a464d1218474fc123ce0adfdc2c1 205-nopie.patch
cf6f9814dee8c524b13f455106e1b92ad4bcbd998bf56bdb0858d1c6c89bfaf7ee8f75514d3e7092137f06d40b8419b6a5d2434e48d2ec32a83aa9c2ced45558 207-static-pie.patch
d08d7ead2de0429e5c9055d5b029ec2be9a8c821d22cecaf9b51f633652c493333f98963d9267fa2fa63850c50ae5eefd5f59e5910ec10d20044dac082182a8b libgcc-always-build-gcceh.a.patch
+e5ee0d18eb58e2624e745986ded7eb310fcda4dccca6c8fb368c6c9bdd98f0d54771fdfc3ab3315f09d1f22d400cf30d4b807afdbcd963cc9aa6cd60df2afa87 libada-cross-shared.patch
600fe5098dc54edaa9808fd5717af9dec058953f9ad37d49cfba1db4f7e9a7a8f02019342f75157fc575946fa693259422184de27b7ecc8386d9f3ecc0f7cc5d gcc-4.9-musl-fortify.patch
dbe0ee917fc7668571722364ab7c806731e3a31e8bfa30b4941b28b16b877d2a32b4a3897ef533399a28f82d43cac9b28e92de0493f0e779046db56584e07fa4 gcc-6.1-musl-libssp.patch
bda845a6aa1854d2c883910b115f79ccfa93dfc2b5eac69a3a236d83eb34cadc140731d616ffc24698c7abc8878dd15f231bcc5119f1860e575a120b311706c7 boehm-gc-musl.patch
diff --git a/main/gcc/libada-cross-shared.patch b/main/gcc/libada-cross-shared.patch
new file mode 100644
index 0000000000..0678f9cafe
--- /dev/null
+++ b/main/gcc/libada-cross-shared.patch
@@ -0,0 +1,22 @@
+--- gcc-4.8.2/libada/configure.ac.orig 2013-01-14 22:15:04.000000000 +0400
++++ gcc-4.8.2/libada/configure.ac 2014-01-21 06:53:04.254453731 +0400
+@@ -127,7 +127,7 @@
+ AC_PROG_LN_S
+
+ # Determine what to build for 'gnatlib'
+-if test $build = $target \
++if test $host = $target \
+ && test ${enable_shared} = yes ; then
+ # Note that build=target is almost certainly the wrong test; FIXME
+ default_gnatlib_target="gnatlib-shared"
+--- gcc-4.8.2/libada/configure.orig 2013-10-16 11:27:58.000000000 +0400
++++ gcc-4.8.2/libada/configure 2014-01-21 06:53:26.727581207 +0400
+@@ -2951,7 +2951,7 @@
+
+
+ # Determine what to build for 'gnatlib'
+-if test $build = $target \
++if test $host = $target \
+ && test ${enable_shared} = yes ; then
+ # Note that build=target is almost certainly the wrong test; FIXME
+ default_gnatlib_target="gnatlib-shared"