aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-06 05:45:49 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 05:47:05 +0000
commit1830e485126ea9a95d763317fb0c508c1ff297d2 (patch)
tree687b807c806a7cbcf4ba534c1a75aa3f3f5bc23f /main/gcc
parentd3f3951d4d91b7ec8756278793e6f60dcc344e0c (diff)
downloadaports-1830e485126ea9a95d763317fb0c508c1ff297d2.tar.bz2
aports-1830e485126ea9a95d763317fb0c508c1ff297d2.tar.xz
main/gcc: disable libmpx
it does not work with musl at the time being
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 3aaf42ceed..eca33db35d 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -8,7 +8,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -249,8 +249,9 @@ build() {
case "$CTARGET_LIBC" in
musl)
# musl does not support mudflap, or libsanitizer
+ # libmpx uses secure_getenv and struct _libc_fpstate not present in musl
# alpine musl provides libssp_nonshared.a, so we don't need libssp either
- _libc_configure="--disable-libssp --disable-libmudflap --disable-libsanitizer"
+ _libc_configure="--disable-libssp --disable-libmpx --disable-libmudflap --disable-libsanitizer"
_symvers="--disable-symvers"
export libat_cv_have_ifunc=no
;;