aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-08-28 16:59:32 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-08-28 16:59:32 +0000
commit61dd7a457049d16ed051eb2f693dca4950af469b (patch)
tree650f861246fefb6f0991234c529b44fbe765ec4d /main/gcc
parent5306be2044ac74512103cab619a8e864babd2899 (diff)
downloadaports-61dd7a457049d16ed051eb2f693dca4950af469b.tar.bz2
aports-61dd7a457049d16ed051eb2f693dca4950af469b.tar.xz
main/gcc: upgrade to 5.2.0
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/086_all_gcc5-pie-copy-relocs-pr65780.patch48
-rw-r--r--main/gcc/APKBUILD16
-rw-r--r--main/gcc/arm-pr65932.patch19
3 files changed, 27 insertions, 56 deletions
diff --git a/main/gcc/086_all_gcc5-pie-copy-relocs-pr65780.patch b/main/gcc/086_all_gcc5-pie-copy-relocs-pr65780.patch
deleted file mode 100644
index 3e6b8b5bd1..0000000000
--- a/main/gcc/086_all_gcc5-pie-copy-relocs-pr65780.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-https://gcc.gnu.org/PR65780
-
-2015-04-22 Jakub Jelinek <jakub@redhat.com>
-
- PR target/65780
- * config/s390/linux.h (TARGET_BINDS_LOCAL_P): Define to
- default_binds_local_p_2.
- * config/arm/linux-elf.h (TARGET_BINDS_LOCAL_P): Likewise.
- * config/aarch64/aarch64-linux.h (TARGET_BINDS_LOCAL_P): Likewise.
-
---- a/gcc/config/s390/linux.h.jj 2015-01-05 13:07:16.000000000 +0100
-+++ b/gcc/config/s390/linux.h 2015-04-22 17:39:38.880273650 +0200
-@@ -90,4 +90,10 @@ along with GCC; see the file COPYING3.
- #undef TARGET_LIBC_HAS_FUNCTION
- #define TARGET_LIBC_HAS_FUNCTION gnu_libc_has_function
-
-+/* Uninitialized common symbols in non-PIE executables, even with
-+ strong definitions in dependent shared libraries, will resolve
-+ to COPY relocated symbol in the executable. See PR65780. */
-+#undef TARGET_BINDS_LOCAL_P
-+#define TARGET_BINDS_LOCAL_P default_binds_local_p_2
-+
- #endif
---- a/gcc/config/arm/linux-elf.h.jj 2015-01-05 13:07:16.000000000 +0100
-+++ b/gcc/config/arm/linux-elf.h 2015-04-22 17:42:35.979420149 +0200
-@@ -118,3 +118,9 @@
- /* Add .note.GNU-stack. */
- #undef NEED_INDICATE_EXEC_STACK
- #define NEED_INDICATE_EXEC_STACK 1
-+
-+/* Uninitialized common symbols in non-PIE executables, even with
-+ strong definitions in dependent shared libraries, will resolve
-+ to COPY relocated symbol in the executable. See PR65780. */
-+#undef TARGET_BINDS_LOCAL_P
-+#define TARGET_BINDS_LOCAL_P default_binds_local_p_2
---- a/gcc/config/aarch64/aarch64-linux.h.jj 2015-01-05 13:07:17.000000000 +0100
-+++ b/gcc/config/aarch64/aarch64-linux.h 2015-04-22 17:40:46.395185820 +0200
-@@ -69,4 +69,10 @@
-
- #define TARGET_ASM_FILE_END file_end_indicate_exec_stack
-
-+/* Uninitialized common symbols in non-PIE executables, even with
-+ strong definitions in dependent shared libraries, will resolve
-+ to COPY relocated symbol in the executable. See PR65780. */
-+#undef TARGET_BINDS_LOCAL_P
-+#define TARGET_BINDS_LOCAL_P default_binds_local_p_2
-+
- #endif /* GCC_AARCH64_LINUX_H */
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index f6ad79c0c2..89d818309e 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gcc
-pkgver=5.1.0
+pkgver=5.2.0
_cross=""
[ "$BOOTSTRAP" = "noheaders" ] && pkgname="gcc-pass1"
[ "$BOOTSTRAP" = "nolibc" ] && pkgname="gcc-pass2"
@@ -153,7 +153,6 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.bz2
053_all_libitm-no-fortify-source.patch
067_all_gcc-poison-system-directories.patch
074_all_gcc5_isl-dl.patch
- 086_all_gcc5-pie-copy-relocs-pr65780.patch
090_all_pr55930-dependency-tracking.patch
101_all_gcc49_configure.patch
@@ -177,6 +176,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.bz2
212-gthr.patch
213-posix_memalign.patch
214-stdint.patch
+ arm-pr65932.patch
libgcc-always-build-gcceh.a.patch
gcc-4.8-musl-libssp.patch
@@ -639,7 +639,7 @@ gnat() {
mv "$pkgdir"/usr/bin/*gnat* "$subpkgdir"/usr/bin/ || return 1
}
-md5sums="d5525b1127d07d215960e6051c5da35e gcc-5.1.0.tar.bz2
+md5sums="a51bcfeb3da7dd4c623e27207ed43467 gcc-5.2.0.tar.bz2
d7cd6a27c8801e66cbaa964a039ecfdb ecj-latest.jar
f4be3dc5dcbe42df9274774ddb908d4a 005_all_gcc-spec-env.patch
56147d4efc0a64dd193f5d211d5b9a61 010_all_default-fortify-source.patch
@@ -651,7 +651,6 @@ d8692c56f04b92667096f59d843e95c5 051_all_libiberty-pic.patch
9cb2d475322dc61a1fe35054257001c5 053_all_libitm-no-fortify-source.patch
5d4fc1966db6860c43e2547be89bc666 067_all_gcc-poison-system-directories.patch
bbfb766dce636e8bc41e5e4cdc7731b4 074_all_gcc5_isl-dl.patch
-7fb79fc1d5b28d9cd103b1411eb75f2c 086_all_gcc5-pie-copy-relocs-pr65780.patch
7d4c5c1becd11ab4fe0ef9088f96e638 090_all_pr55930-dependency-tracking.patch
096f21a5269adc12cc967c2a63620fa0 101_all_gcc49_configure.patch
2a8d6a9046efc9f44449b012cf12d7fd 102_all_gcc48_config.in.patch
@@ -673,6 +672,7 @@ f44f290f4d35f99fd682c0c114f35df9 210-fixincludes.patch
8967273be5dd491d79530c81d9211f14 212-gthr.patch
81e7ef6d8bbd374fb73bc3edf6912228 213-posix_memalign.patch
ab90688b8df55e3602b5eb83ef272699 214-stdint.patch
+d718d3a14ed8c36b7a73a75076a0ab34 arm-pr65932.patch
504c7dd8651c5d98229892c4cd9ea591 libgcc-always-build-gcceh.a.patch
0d0a41c02802b85c8f1b78ce28544f92 gcc-4.8-musl-libssp.patch
9e658e590bc51be611f39945183f6aa2 gcc-4.9-musl-fortify.patch
@@ -690,7 +690,7 @@ a2f435d81e872a73a8b44a4581832af0 vanilla.specs
17a31b8580de9dd9c06a1ed96886d538 hardenednossp.specs
33ce2d221828a2d03978da52ba609524 hardenednopie.specs
5c431710b72c6ec16ed21bcca83d9f87 hardenednopiessp.specs"
-sha256sums="b7dafdf89cbb0e20333dbf5b5349319ae06e3d1a30bf3515b5488f7e89dca5ad gcc-5.1.0.tar.bz2
+sha256sums="5f835b04b5f7dd4f4d2dc96190ec1621b8d89f2dc6f638f9f8bc1b1014ba8cad gcc-5.2.0.tar.bz2
98fd128f1d374d9e42fd9d4836bdd249c6d511ebc6c0df17fbc1b9df96c3d781 ecj-latest.jar
aac72f6c1940153084d5ffca8040db6e2eb9e75f15915b8f3f695bb0cd44716b 005_all_gcc-spec-env.patch
9f354a85bb1914b9a9cbd82e2a48fbd3aca384b801285b27512eb2b238c48635 010_all_default-fortify-source.patch
@@ -702,7 +702,6 @@ da6bbb5dc654d5e1df8ecae5c9ebb56265426c405931f14f5878248b8c79f78d 051_all_libibe
545a0ffcf70fdd712c7e881cbd29e657f499b5e13cec5d0516b9fa277cefe67b 053_all_libitm-no-fortify-source.patch
278fe3352c38da7804292ddf2119aadf9a88999042cb8516301989c61a50e3f0 067_all_gcc-poison-system-directories.patch
4500e1b6aaf3f119abfe6712cddc9b1115906b8460bd0b82514473654fbed422 074_all_gcc5_isl-dl.patch
-bcb8dba8dad6daa4e10d1274e298a05b9e522223641ab79599a8d8472d099fa6 086_all_gcc5-pie-copy-relocs-pr65780.patch
f108fdc8bb62aea4245ff9ad3d314603c69f7993f4c81de3a4c92a44b80b206e 090_all_pr55930-dependency-tracking.patch
d86a599414c8378aa1cfde75d7c2f94e7345c34063ff0114432c6de119eba2fc 101_all_gcc49_configure.patch
f301cce95609650f57c5212b38daf5288b4e7c5fa37ae2892664d4c8ceaadfbf 102_all_gcc48_config.in.patch
@@ -724,6 +723,7 @@ a151a3f3e34c52ce74718c768b25c7f50c9eab96f04943f4cdb2bd4c1bb7958e 210-fixinclude
b81fda1453d7f33ab81b526450e40132fa37d396e9cc6a76642ae7139cb74771 212-gthr.patch
87370f7854063bcf5f57bff931684c228370668ccf5ecd8e36ea9cf7c7455b16 213-posix_memalign.patch
a4909818a9811a8b8e074f5ab5b47d77075411a5192f3ebe4ed9766463be183b 214-stdint.patch
+ca2567deb978ffa9566ca656ad1713edee2d90268aa0740b76e2658419b8b888 arm-pr65932.patch
1975189156d70f5428cb7f1516533965d1c8734f3009fc89a9b8e289b72326f1 libgcc-always-build-gcceh.a.patch
80b76ca30dcaf07481ab102869d741f044c7e5235f462182bc27467baacda9a4 gcc-4.8-musl-libssp.patch
dc93f97dff28b872f9c7e241fb87a3eca0271f706534d196b3517781b05667fa gcc-4.9-musl-fortify.patch
@@ -741,7 +741,7 @@ d6c7fc1820a4fa285297c299c255fe2f19ce1695486f20edd098252a97545e6a ada-shared.pat
50a46bb1c4d209ce687d13e74cc9e4e0b87cef4a8165d22fb9be243c9cf08374 hardenednossp.specs
8eccfcf282fb54aadede7c23a8b5b843c0a63a55485e74d4332ab49025d38e78 hardenednopie.specs
af85685ff501f5e0eaaa394628365425486dafe4780f0f683a4536ab60173cdf hardenednopiessp.specs"
-sha512sums="30f6a94d3adb25bc51fcaddf32a6c41429f569eeb9ed64330445b1296f99998fbfa03277b375be4f7b2b80f519910ef88e4149db7cd9031e2c61a49f501bde94 gcc-5.1.0.tar.bz2
+sha512sums="844120349ec04465dcea52d8ec747f1cbbc9d76a39fe3d8ef5e6b93614e63d718862d60d0a1c1cbf59ffc7815562287d0a2e536a6b220cebcd0b8de4ba35e715 gcc-5.2.0.tar.bz2
d4e1bf7538ace56e3d69fa91da5bbd16c272923b4de0a9d8dee23ea2b75f9f38c603de72fc4061df49285c450b63f3df211cee5270e9fffc5447445d1a9c9e4e ecj-latest.jar
486ddf9293f11db70fa277196ba95a3a5a45c181c99d6460ef6b2ad7396a1e75533ef29d5c47f30319acf4fb731a40f312ba1c32105b23ee905a78b017e7aaf0 005_all_gcc-spec-env.patch
5c95afffbd6dc49c252fd3723142d240067470f4c347237c38d37cafe30f6251cd9bebad62d54b75ceacdccab3a2d806a1d17ad94122ce6a84229e099bac4379 010_all_default-fortify-source.patch
@@ -753,7 +753,6 @@ d35a3ac7e13a4446921a90e1ff3eec1079840c845f9d523c868e24ae21f94cf69ba041de5341ebef
e7a2eb1b1870e199d6fd753d065781575656fa12baa264f96c5d179689d88c31b8a3f92a5dae96088c05e96aa2bda138364ad7dbcc79e1819a102f192cbb7bab 053_all_libitm-no-fortify-source.patch
9798f22203df092cc8c96a59da211431f4bc3dfc52676f288f0462ae207e5c26fa205b146e9e5dbff0d79755bd59eb980801e3f2c2ca556433a2994d99096728 067_all_gcc-poison-system-directories.patch
a197419f31395972f63545fba41ca1a50164471f868810fa913dcf1639dc91f9005766e97af303d56e8dfbc6816d15dbb78e3dfcdd7f4aa80981af1502518564 074_all_gcc5_isl-dl.patch
-18aa696350d0272af70920fc4736c3a8c81b59624938dd684245a7626dc444d99bbe486401557e6a024aa4bd19240930f4afcd80f39c602dd207d273640171ce 086_all_gcc5-pie-copy-relocs-pr65780.patch
4a328d1e1a56c20166307edcfa322068915784d9c08025b7f81cf69714da48fc266b6d34f77b9135c2f10da830d9df408276a1b78d1fd218637c2823506593c2 090_all_pr55930-dependency-tracking.patch
618a8d037ccad15e60182acc9c85ba844cb9b5800a22ece0b814e43541b01b4e390a2847f86debb351f4b05580241747fde87e86a17060744e7bb2b9a3dc5bd4 101_all_gcc49_configure.patch
21770259c7916e55568027926e4a543eea468b04436cc61c28f749be5a6635c48e68b7924a8eb19a76733a9d2f00921ba06faddaedbf14b1cdad5ab1810cc6c6 102_all_gcc48_config.in.patch
@@ -775,6 +774,7 @@ f9d3d10a178b50cef06e2b16756d31662faf88e7f4a257efb7093eea9e104dd3b33fdf7f838a8f60
f53475e3cc7953f5f2bfe5079b89c16d30bc09ddfc359dcd8bf87604f0899c0da07505b9bbc7ab8a844edd0911e0fc5745b60b3f724d5e5d30993372176c227f 212-gthr.patch
27e1a29e039dcc4c5190416702d1d95d48fbaeaac6440d81584989fe71a12f7bf5a484241ced9aa82b9f050eb3be8786d9584ba5299d304e7ed30506755880bc 213-posix_memalign.patch
27cbc715643b2b28d213bbc31ad68d8ca4fc2ca730b6967dce827ec9d4c54b74fa6c2ce021d91684984680b07734ab07ef9b824aec2281ed3f632fb9335cc3f6 214-stdint.patch
+d0a95aa7253635ff8928840901436c94f50ecb907327b539d05fbf16611a14824b898a199615bf586f2f83910fb390820c707cb3784bdb4e229a6088644c49dd arm-pr65932.patch
d08d7ead2de0429e5c9055d5b029ec2be9a8c821d22cecaf9b51f633652c493333f98963d9267fa2fa63850c50ae5eefd5f59e5910ec10d20044dac082182a8b libgcc-always-build-gcceh.a.patch
e6d9b103c128e5d4eca515b1496d78b05708de770597c883daddd95ea41e77b5ef1be613b989357cc870a7efd9e43b011022c2d302e7056cff7b69e764906ff2 gcc-4.8-musl-libssp.patch
600fe5098dc54edaa9808fd5717af9dec058953f9ad37d49cfba1db4f7e9a7a8f02019342f75157fc575946fa693259422184de27b7ecc8386d9f3ecc0f7cc5d gcc-4.9-musl-fortify.patch
diff --git a/main/gcc/arm-pr65932.patch b/main/gcc/arm-pr65932.patch
new file mode 100644
index 0000000000..e7287d018e
--- /dev/null
+++ b/main/gcc/arm-pr65932.patch
@@ -0,0 +1,19 @@
+--- gcc/gcc/config/arm/arm.h (revision 224441)
++++ gcc/gcc/config/arm/arm.h (working copy)
+@@ -523,16 +523,10 @@ extern int arm_arch_crc;
+ type, but kept valid in the wider mode. The signedness of the
+ extension may differ from that of the type. */
+
+-/* It is far faster to zero extend chars than to sign extend them */
+-
+ #define PROMOTE_MODE(MODE, UNSIGNEDP, TYPE) \
+ if (GET_MODE_CLASS (MODE) == MODE_INT \
+ && GET_MODE_SIZE (MODE) < 4) \
+ { \
+- if (MODE == QImode) \
+- UNSIGNEDP = 1; \
+- else if (MODE == HImode) \
+- UNSIGNEDP = 1; \
+ (MODE) = SImode; \
+ }
+