aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-01-24 18:18:21 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-01-24 18:58:40 +0000
commit625464be2139d8f92fc932d5eb8426202f8158fa (patch)
treee5bb8f9b338b0f14ad3f90eaeb521a2ad369893f /main/gcc
parent1328c94d12a24632191f20e762f6ebad5059750b (diff)
downloadaports-625464be2139d8f92fc932d5eb8426202f8158fa.tar.bz2
aports-625464be2139d8f92fc932d5eb8426202f8158fa.tar.xz
main/gcc: do not paxmark if cross-building
paxctl rejects the binaries as invalid ELF images, because they aren't built for the system architecture
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index f90cd60be5..a2f7444a3e 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -369,7 +369,10 @@ package() {
mv "$pkgdir"/usr/lib/*-gdb.py \
"$pkgdir"/usr/share/gdb/python/auto-load/usr/lib/
- paxmark -pmrs "$pkgdir"/$_gcclibexec/cc1 || return 1
+ # only paxmark if cross-compiling, otherwise paxctl fails
+ if [ "$CBUILD" = "$CTARGET" ]; then
+ paxmark -pmrs "$pkgdir"/$_gcclibexec/cc1 || return 1
+ fi
# move ada runtime libs
if $LANG_ADA; then