aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-11 18:15:55 +0000
committerTimo Teräs <timo.teras@iki.fi>2014-12-11 18:15:55 +0000
commit9ea0950e8a54a277f3861bbff449a7b40ddc53fc (patch)
treee938b2729f31b4a86239034f73ab2383cb7904af /main/gcc
parentbe6a2024f4aca839baa459ffdc9019521df0955c (diff)
downloadaports-9ea0950e8a54a277f3861bbff449a7b40ddc53fc.tar.bz2
aports-9ea0950e8a54a277f3861bbff449a7b40ddc53fc.tar.xz
main/gcc: apply bug fix from pr63740 (should fix arm bootstrap)
bump pkgrel as this seems to affect thing in general
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD6
-rw-r--r--main/gcc/pr63740.patch17
2 files changed, 22 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index 93af3e5b76..30c9007153 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -8,7 +8,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=0
+pkgrel=1
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -177,6 +177,7 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.bz2
fix-gcj-musl.patch
fix-gcj-iconv-musl.patch
musl-posix_memalign-c++.patch
+ pr63740.patch
gcc-4.8-build-args.patch
fix-cxxflags-passing.patch
@@ -660,6 +661,7 @@ a695d7648509b4f8e18b389a19e6037c gcc-spec-env.patch
14fc0a0b925ef911ce78cd030fe58902 fix-gcj-musl.patch
e17bbb0fe802974e20645b4182b4c410 fix-gcj-iconv-musl.patch
4ec9d6c3ed7734811d9a8996dbc4884f musl-posix_memalign-c++.patch
+c8968669baced4afc2550147a5e18cc6 pr63740.patch
0a2041bbf83648e6c4f6d3484f7249ca gcc-4.8-build-args.patch
4aea37d334ab00bb6bba37cd8c481367 fix-cxxflags-passing.patch
87684048ecaaf0e046983bc2782292dd fix-cxxflags-for-target.patch
@@ -705,6 +707,7 @@ f5473c6aea96d5137defd68898ba31042944a3f3ed26c05b964a40bd876c6f47 gcc-pure64.pat
22c78cc4a2658ff574e7ded1e5bc765a4f81f730d12e72d5883fe0bf73e71220 fix-gcj-musl.patch
51782c972ab828eb4ccb3ca3570341d025b2ae9a8e8fd8188cefb29c5f87401b fix-gcj-iconv-musl.patch
24d8dbbb7eb4cbf1bc9aa215c94482f76258d5ea67892a491de21f49eb68c028 musl-posix_memalign-c++.patch
+eedd8697f42a3b01e6957676343cce486b16fe8b2e4d1f2926c43db391c743c1 pr63740.patch
bd7a6f514fcc457f29e5fda157203f3bcd013aeba5d53b3459196eef3ce752ab gcc-4.8-build-args.patch
a395ba4cf047c48cac56985726fddf0948f4425c9f1a0c9ddba1812b2b3d8300 fix-cxxflags-passing.patch
a5678380e887dbf600c59273d382e81c10f89d28e422238a617d0a43ad5c5a69 fix-cxxflags-for-target.patch
@@ -750,6 +753,7 @@ bda845a6aa1854d2c883910b115f79ccfa93dfc2b5eac69a3a236d83eb34cadc140731d616ffc246
f89ddeb21bc8f97e6a850a6b70b4501a8f3e49a4bc8cc82897488decda5d98ad01cb7f6c8b392d452e9579924a523bc75da6e0648c1c976d42e40af48b10343b fix-gcj-musl.patch
54d67cc008b735e47771314171930c5d8b8f5f5dc97fcf4214824c105c808f3e75d22d5a4fdf5068ed0457fa0d46c60cfb442e276259a4a5e9b8722a027d18e6 fix-gcj-iconv-musl.patch
7de81fc8c7eb36690949eb30082515454978440a8f389b12407ac5e9125ef6824d6059ffb5b063ab1ccc6c4827b1a6a0984b538f056b85e3171800a6f723ec8b musl-posix_memalign-c++.patch
+095281d940ad7504ed7071cc9800d81db33eb4aa5465696ef7b12bf1213dbdfa701f4392095c5167b331c38219b19d25a0798524b319f1c77aa8522d76d8c92c pr63740.patch
abe9aaf9aa956058d0386a4396a511d176a46bb3906b90e952383646cdc158cbeb0a5dc616a1ccb1ca7d49fd0b5e351532aa15a3b13362abbf1ca4266f54a687 gcc-4.8-build-args.patch
35d6d59f0b7b968f282f56767c9e0823a7bdc5aa0d450aca50fbd802649a7ca608b47671244a3faa208a9b0d6832cabb5a22724157dc817b2c0ad63d09f93282 fix-cxxflags-passing.patch
c731f4aaaa65c8950e1b2bd9331410f92d378fd8c7e718532dccaa27ee11984d51d74216c3611e89a802325b81d7f184116839dce2dab50cae9b643c20a82fe7 fix-cxxflags-for-target.patch
diff --git a/main/gcc/pr63740.patch b/main/gcc/pr63740.patch
new file mode 100644
index 0000000000..234d468731
--- /dev/null
+++ b/main/gcc/pr63740.patch
@@ -0,0 +1,17 @@
+https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63740
+
+--- trunk/gcc/lra-lives.c 2014/06/16 09:25:26 211700
++++ trunk/gcc/lra-lives.c 2014/06/16 09:58:34 211701
+@@ -558,7 +558,11 @@
+ /* It might be 'inheritance pseudo <- reload pseudo'. */
+ || (src_regno >= lra_constraint_new_regno_start
+ && ((int) REGNO (SET_DEST (set))
+- >= lra_constraint_new_regno_start))))
++ >= lra_constraint_new_regno_start)
++ /* Remember to skip special cases where src/dest regnos are
++ the same, e.g. insn SET pattern has matching constraints
++ like =r,0. */
++ && src_regno != (int) REGNO (SET_DEST (set)))))
+ {
+ int hard_regno = -1, regno = -1;
+