aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-05-28 08:05:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-05-28 08:05:18 +0000
commitbaddb44e9e5164760fcc384d2ed7889aa3d7415a (patch)
treef347a0aaa6b18851d237f0bd91d8423c5da4571e /main/gcc
parentf3f0096346f5123518483533d44d7d2a77518e15 (diff)
downloadaports-baddb44e9e5164760fcc384d2ed7889aa3d7415a.tar.bz2
aports-baddb44e9e5164760fcc384d2ed7889aa3d7415a.tar.xz
main/gcc: support i586-alpine-linux-musl triplet
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index d490ca2dd9..aae7e5c8a3 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -8,7 +8,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=5
+pkgrel=6
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -254,6 +254,7 @@ build() {
armv6-*-*-*eabihf) _arch_configure="--with-arch=armv6zk --with-tune=arm1176jzf-s --with-fpu=vfp --with-float=hard --with-abi=aapcs-linux";;
mipsel-*-*-*) _arch_configure="--with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=32 --with-mips-plt --with-float=hard --with-abi=32";;
i486-*-*-*) _arch_configure="--with-arch=i486 --with-tune=generic --enable-cld";;
+ i586-*-*-*) _arch_configure="--with-arch=i586 --with-tune=generic --enable-cld";;
esac
case "$CTARGET_LIBC" in