aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-01-26 18:07:03 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-01-26 18:07:03 +0000
commitd6f19c94c4fbd3b7373d349f8170f8d85f97edf5 (patch)
treef3e02fd3cc30cbed720b31ca56d3023b1ef0dc19 /main/gcc
parentbeba0b6a9f91ff0dda6f6315d35f20ad63eba233 (diff)
downloadaports-d6f19c94c4fbd3b7373d349f8170f8d85f97edf5.tar.bz2
aports-d6f19c94c4fbd3b7373d349f8170f8d85f97edf5.tar.xz
main/gcc: add flags for ppc64le (ref github #765)
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD1
1 files changed, 1 insertions, 0 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index f90cd60be5..c21f3173f3 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -245,6 +245,7 @@ build() {
armv7-*-*-*eabihf) _arch_configure="--with-arch=armv7-a --with-tune=generic-armv7-a --with-fpu=vfpv3-d16 --with-float=hard --with-abi=aapcs-linux --with-mode=thumb";;
mipsel-*-*-*) _arch_configure="--with-arch-32=mips2 --with-tune-32=mips32 --with-fp-32=32 --with-mips-plt --with-float=hard --with-abi=32";;
powerpc-*-*-*) _arch_configure="--enable-secureplt --enable-decimal-float=no";;
+ powerpc64-*-*-*) _arch_configure="--with-abi=elfv2 --enable-secureplt --enable-decimal-float=no";;
i486-*-*-*) _arch_configure="--with-arch=i486 --with-tune=generic --enable-cld";;
i586-*-*-*) _arch_configure="--with-arch=i586 --with-tune=generic --enable-cld";;
s390x-*-*-*) _arch_configure="--with-arch=z196 --with-tune=zEC12 --with-zarch --with-long-double-128 --enable-decimal-float";;