aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-01-24 20:48:03 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-01-24 20:48:03 +0000
commitedae9a35e20069098a517b953d8d49d3f534a373 (patch)
tree2262136aeb7868eb13d600fcda32caf0368bed41 /main/gcc
parent4e3c15461723fcafa7bca08c3a0dafa11e7954e1 (diff)
downloadaports-edae9a35e20069098a517b953d8d49d3f534a373.tar.bz2
aports-edae9a35e20069098a517b953d8d49d3f534a373.tar.xz
main/gcc: more paxmark cleanup
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/APKBUILD5
1 files changed, 1 insertions, 4 deletions
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index a2f7444a3e..f90cd60be5 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -369,10 +369,7 @@ package() {
mv "$pkgdir"/usr/lib/*-gdb.py \
"$pkgdir"/usr/share/gdb/python/auto-load/usr/lib/
- # only paxmark if cross-compiling, otherwise paxctl fails
- if [ "$CBUILD" = "$CTARGET" ]; then
- paxmark -pmrs "$pkgdir"/$_gcclibexec/cc1 || return 1
- fi
+ paxmark -pmrs "$pkgdir"/$_gcclibexec/cc1 || return 1
# move ada runtime libs
if $LANG_ADA; then