aboutsummaryrefslogtreecommitdiffstats
path: root/main/gimp/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-02 13:53:33 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-02 13:53:33 +0000
commit8083a74b34a0d7b12e24bf15be3db5e77635e7b0 (patch)
treea53a122fbe993bed23ba80c578b9dfa0ca129044 /main/gimp/APKBUILD
parentccfebb5a5e5c3b4547896cfde292521daceb9de5 (diff)
downloadaports-8083a74b34a0d7b12e24bf15be3db5e77635e7b0.tar.bz2
aports-8083a74b34a0d7b12e24bf15be3db5e77635e7b0.tar.xz
main/gimp: fix underlinking, enable lcms, tiff, poppler and gio
Diffstat (limited to 'main/gimp/APKBUILD')
-rw-r--r--main/gimp/APKBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/main/gimp/APKBUILD b/main/gimp/APKBUILD
index d297aae275..208d164f7d 100644
--- a/main/gimp/APKBUILD
+++ b/main/gimp/APKBUILD
@@ -1,20 +1,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gimp
pkgver=2.6.11
-pkgrel=6
+pkgrel=7
pkgdesc="GNU Image Manipulation Program"
url="http://www.gimp.org/"
arch="all"
license="GPL"
makedepends="gtk+-dev libxpm-dev libxmu-dev librsvg-dev dbus-glib-dev
libexif-dev desktop-file-utils intltool gegl-dev tiff-dev
- jpeg-dev libpng-dev"
+ jpeg-dev libpng-dev iso-codes lcms-dev poppler-gtk-dev
+ autoconf automake libtool"
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="ftp://ftp.$pkgname.org/pub/$pkgname/v2.6/$pkgname-$pkgver.tar.bz2
gimp-libpng1.5-compat.patch
gimp-curl-fix.patch
- cve-2011-2896.patch"
+ cve-2011-2896.patch
+ gimp-poppler-0.18.patch
+ gimp-2.6.11-underlinking.patch
+ "
_builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
@@ -28,18 +32,20 @@ prepare() {
;;
esac
done
+ libtoolize --force || return 1
+ aclocal -I m4macros && autoconf && automake || return 1
}
build() {
cd "$_builddir"
./configure --prefix=/usr \
+ --disable-dependency-tracking \
--sysconfdir=/etc \
--enable-mp \
--enable-gimp-console \
--enable-gimp-remote \
- --disable-devel-docs \
--disable-python \
- --without-gvfs \
+ --with-gvfs \
--without-gnomevfs \
--with-gif-compression=lzw \
--without-aa || return 1
@@ -56,4 +62,6 @@ package() {
md5sums="bb2939fe13e54fc7255cef5d097bb5dd gimp-2.6.11.tar.bz2
7dfc4006676fdea887f1883ccc6c7772 gimp-libpng1.5-compat.patch
678010acec374e06140e65f7de24ff69 gimp-curl-fix.patch
-c317eae455c808b8434e9b600afee648 cve-2011-2896.patch"
+c317eae455c808b8434e9b600afee648 cve-2011-2896.patch
+bfc73f80e911ed7a7d500d80973469f1 gimp-poppler-0.18.patch
+b1fde5d284544440ae2c556b380800ab gimp-2.6.11-underlinking.patch"