aboutsummaryrefslogtreecommitdiffstats
path: root/main/gnupg1
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-24 09:03:58 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-24 09:04:48 +0000
commit3263ec3f060cbe120dad859de59d6aaf714d3396 (patch)
treed176831efad0a7552bc7de1f9245613abb1942b7 /main/gnupg1
parent9a262ad18864d1a101bdd201941860cc37581b48 (diff)
downloadaports-3263ec3f060cbe120dad859de59d6aaf714d3396.tar.bz2
aports-3263ec3f060cbe120dad859de59d6aaf714d3396.tar.xz
main/gnupg1: add gnupg 1.x version for musl builds
Diffstat (limited to 'main/gnupg1')
-rw-r--r--main/gnupg1/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/main/gnupg1/APKBUILD b/main/gnupg1/APKBUILD
new file mode 100644
index 0000000000..f7ffe6e170
--- /dev/null
+++ b/main/gnupg1/APKBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnupg1
+pkgver=1.4.16
+pkgrel=0
+pkgdesc="GNU Privacy Guard 1 - a PGP replacement tool"
+url="http://www.gnupg.org/"
+arch="all"
+license="GPL"
+depends="pinentry"
+makedepends="curl-dev libassuan libksba-dev libgcrypt-dev libgpg-error-dev
+ zlib-dev libiconv-dev libassuan-dev"
+subpackages="$pkgname-doc"
+provides="gnupg"
+source="ftp://ftp.gnupg.org/gcrypt/gnupg/gnupg-$pkgver.tar.bz2"
+
+_builddir="$srcdir/gnupg-$pkgver"
+prepare() {
+ cd "$_builddir"
+
+ # Fix PIC definitions
+ sed -i -e 's:PIC:__PIC__:' \
+ mpi/i386/mpih-add1.S \
+ mpi/i386/mpih-sub1.S \
+ intl/relocatable.c \
+ || return 1
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS="$CFLAGS -g"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-nls \
+ --enable-noexecstack \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install
+}
+
+md5sums="6df73c57d3ece1dd36dc2a7679f00fb0 gnupg-1.4.16.tar.bz2"
+sha256sums="7b3b748e6aaa338092a0b26b1730cd9355765b55e3684f58dd70f9a1b00f4a2f gnupg-1.4.16.tar.bz2"
+sha512sums="62bccf22211c25cf2ffbf9d35b8f47211e3a71fd92828705d12b23e7d658c9c65c6d845eb5e887e0d855d90a49a5033ecf9de4e22a63e7d3fc052eb1ed33dff4 gnupg-1.4.16.tar.bz2"