aboutsummaryrefslogtreecommitdiffstats
path: root/main/gpicview
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-01-03 10:51:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-01-03 10:51:03 +0000
commitdc578918b72901faec985ed2f5ef8c13ca1b7bb3 (patch)
treeee6b41eabb4509ceed660a7441093ec6835138f1 /main/gpicview
parent2de9e73c507eabeaac32f0d42a8e9e8f6c015a7e (diff)
downloadaports-dc578918b72901faec985ed2f5ef8c13ca1b7bb3.tar.bz2
aports-dc578918b72901faec985ed2f5ef8c13ca1b7bb3.tar.xz
main/gpickview: build fix for libm underlinking
Diffstat (limited to 'main/gpicview')
-rw-r--r--main/gpicview/APKBUILD21
-rw-r--r--main/gpicview/libm-underlinking.patch25
2 files changed, 42 insertions, 4 deletions
diff --git a/main/gpicview/APKBUILD b/main/gpicview/APKBUILD
index 632e68cab3..3f4194d992 100644
--- a/main/gpicview/APKBUILD
+++ b/main/gpicview/APKBUILD
@@ -1,14 +1,26 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gpicview
pkgver=0.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="Picture viewer of the LXDE Desktop"
url="http://wiki.lxde.org/en/GPicView"
arch="all"
license="GPL-2"
depends=
-makedepends="gtk+-dev intltool jpeg-dev"
-source="http://downloads.sourceforge.net/sourceforge/lxde/$pkgname-$pkgver.tar.gz"
+subpackages="$pkgname-lang"
+makedepends="gtk+-dev intltool jpeg-dev autoconf automake libtool"
+source="http://downloads.sourceforge.net/sourceforge/lxde/$pkgname-$pkgver.tar.gz
+ libm-underlinking.patch"
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ libtoolize --force && aclocal && autoconf && automake
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -20,4 +32,5 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="943da9f4a23541accd5acdd4fb69966f gpicview-0.2.2.tar.gz"
+md5sums="943da9f4a23541accd5acdd4fb69966f gpicview-0.2.2.tar.gz
+99fb803a293c88a37b606136f6a5c6ca libm-underlinking.patch"
diff --git a/main/gpicview/libm-underlinking.patch b/main/gpicview/libm-underlinking.patch
new file mode 100644
index 0000000000..a73e0705e8
--- /dev/null
+++ b/main/gpicview/libm-underlinking.patch
@@ -0,0 +1,25 @@
+From 38cc56d08d243c886526d16bad3ee0b6571d6914 Mon Sep 17 00:00:00 2001
+From: Andrea Florio <andrea@opensuse.org>
+Date: Sun, 18 Sep 2011 08:49:36 +0200
+Subject: [PATCH] fixed link with latest ld
+
+---
+ src/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 4a750c5..0e2f058 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -27,7 +27,7 @@ gpicview_SOURCES = \
+
+ # the library search path.
+ # use -nodefaultlibs to prevent linking libstdc++
+-gpicview_LDADD = $(X11_LIBS) $(GTK_LIBS)
++gpicview_LDADD = $(X11_LIBS) $(GTK_LIBS) -lm
+
+ noinst_HEADERS = \
+ glib-mem.h \
+--
+1.7.4.1
+