aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtest/gtest-1.8.1-libversion.patch
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2018-09-26 16:19:01 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-26 17:04:11 +0000
commitc192b978fa520ce25cc5586d3a766719d253b69f (patch)
tree23dab47f7220b32ac084ee1ce2b39405fcf543af /main/gtest/gtest-1.8.1-libversion.patch
parentcb8c901d59cadc7442b9a588fda3fa9b6c8908f3 (diff)
downloadaports-c192b978fa520ce25cc5586d3a766719d253b69f.tar.bz2
aports-c192b978fa520ce25cc5586d3a766719d253b69f.tar.xz
main/gtest: Upgrade to 1.8.1 and more
Diffstat (limited to 'main/gtest/gtest-1.8.1-libversion.patch')
-rw-r--r--main/gtest/gtest-1.8.1-libversion.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/main/gtest/gtest-1.8.1-libversion.patch b/main/gtest/gtest-1.8.1-libversion.patch
new file mode 100644
index 0000000000..08904c1749
--- /dev/null
+++ b/main/gtest/gtest-1.8.1-libversion.patch
@@ -0,0 +1,29 @@
+diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
+index 8a8de1f..3d86a59 100644
+--- a/googlemock/CMakeLists.txt
++++ b/googlemock/CMakeLists.txt
+@@ -109,8 +109,10 @@ if (MSVC)
+ else()
+ cxx_library(gmock "${cxx_strict}" src/gmock-all.cc)
+ target_link_libraries(gmock PUBLIC gtest)
++ set_target_properties(gmock PROPERTIES VERSION ${GOOGLETEST_VERSION})
+ cxx_library(gmock_main "${cxx_strict}" src/gmock_main.cc)
+ target_link_libraries(gmock_main PUBLIC gmock)
++ set_target_properties(gmock_main PROPERTIES VERSION ${GOOGLETEST_VERSION})
+ endif()
+ # If the CMake version supports it, attach header directory information
+ # to the targets for when we are part of a parent build (ie being pulled
+diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
+index 9ee7940..8099130 100644
+--- a/googletest/CMakeLists.txt
++++ b/googletest/CMakeLists.txt
+@@ -131,7 +131,9 @@ endif()
+ # are used for other targets, to ensure that gtest can be compiled by a user
+ # aggressive about warnings.
+ cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
++set_target_properties(gtest PROPERTIES VERSION ${GOOGLETEST_VERSION})
+ cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
++set_target_properties(gtest_main PROPERTIES VERSION ${GOOGLETEST_VERSION})
+ # If the CMake version supports it, attach header directory information
+ # to the targets for when we are part of a parent build (ie being pulled
+ # in via add_subdirectory() rather than being a standalone build).