aboutsummaryrefslogtreecommitdiffstats
path: root/main/gtk+2.0
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-12-31 14:45:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-12-31 16:02:15 +0000
commit416bc8c293bb16fbfc5dd009636780d17124e70e (patch)
tree9deca9503a785fcb67392d3d9210d01731561f51 /main/gtk+2.0
parent75e96f21d51ebfc25a2c2131aabccf75f47a45e5 (diff)
downloadaports-416bc8c293bb16fbfc5dd009636780d17124e70e.tar.bz2
aports-416bc8c293bb16fbfc5dd009636780d17124e70e.tar.xz
main/gtk+2.0: build fix for automake-1.13
Diffstat (limited to 'main/gtk+2.0')
-rw-r--r--main/gtk+2.0/APKBUILD11
-rw-r--r--main/gtk+2.0/automake.patch19
2 files changed, 27 insertions, 3 deletions
diff --git a/main/gtk+2.0/APKBUILD b/main/gtk+2.0/APKBUILD
index 737b9ad5c3..edb30c4ed0 100644
--- a/main/gtk+2.0/APKBUILD
+++ b/main/gtk+2.0/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gtk+2.0
pkgver=2.24.13
-pkgrel=2
+pkgrel=3
pkgdesc="The GTK+ Toolkit (v2)"
url="http://www.gtk.org/"
install="$pkgname.post-install $pkgname.post-upgrade $pkgname.post-deinstall"
@@ -46,6 +46,7 @@ makedepends="pkgconfig
source="http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-$pkgver.tar.xz
xid-collision-debug.patch
gtk2-fixdso.patch
+ automake.patch
"
@@ -58,7 +59,10 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
- libtoolize && autoreconf
+ libtoolize --force \
+ && aclocal -I m4 \
+ && autoconf \
+ && automake --add-missing
}
build() {
@@ -92,4 +96,5 @@ dev() {
md5sums="e949406751df51e1e40e85628005a069 gtk+-2.24.13.tar.xz
22355df723f6ca358e30e6b8f0baace5 xid-collision-debug.patch
-b1f61a42b2fa3c54eb2e0d6c130a0f0a gtk2-fixdso.patch"
+b1f61a42b2fa3c54eb2e0d6c130a0f0a gtk2-fixdso.patch
+785684b98b41e4a7c0d5e2524e27af54 automake.patch"
diff --git a/main/gtk+2.0/automake.patch b/main/gtk+2.0/automake.patch
new file mode 100644
index 0000000000..106597974c
--- /dev/null
+++ b/main/gtk+2.0/automake.patch
@@ -0,0 +1,19 @@
+--- ./configure.in.orig 2012-12-31 14:40:30.297439517 +0000
++++ ./configure.in 2012-12-31 14:40:51.587629835 +0000
+@@ -51,7 +51,7 @@
+ cflags_set=${CFLAGS+set}
+
+ AM_INIT_AUTOMAKE([no-define -Wno-portability dist-bzip2])
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADER(config.h)
+
+ # Support silent build rules, requires at least automake-1.11. Enable
+ # by either passing --enable-silent-rules to configure or passing V=0
+@@ -300,7 +300,6 @@
+
+ # Checks for programs.
+ AC_ISC_POSIX
+-AM_PROG_CC_STDC
+ AM_PROG_CC_C_O
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET