aboutsummaryrefslogtreecommitdiffstats
path: root/main/htop
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-10 16:58:23 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-13 05:44:00 +0000
commitbcb659c09ad1f37f3bdbc15680325a8ea0f0466f (patch)
treeb3b6cd98e1ad35ba7d0b7af47db6f8232d697123 /main/htop
parentbd4ba6414dbdc3165e45311888e6c6446573c00d (diff)
downloadaports-bcb659c09ad1f37f3bdbc15680325a8ea0f0466f.tar.bz2
aports-bcb659c09ad1f37f3bdbc15680325a8ea0f0466f.tar.xz
main/htop: upgrade to python3, clarify license
Diffstat (limited to 'main/htop')
-rw-r--r--main/htop/APKBUILD14
-rw-r--r--main/htop/fix-python-path.patch8
2 files changed, 16 insertions, 6 deletions
diff --git a/main/htop/APKBUILD b/main/htop/APKBUILD
index 03355ceb92..cc63071c1e 100644
--- a/main/htop/APKBUILD
+++ b/main/htop/APKBUILD
@@ -3,15 +3,16 @@
pkgname=htop
pkgver=2.2.0
pkgrel=0
-pkgdesc="An interactive process viewer"
-url="http://hisham.hm/htop/"
+pkgdesc="Interactive process viewer"
+url="http://hisham.hm/htop"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
depends=""
-makedepends="ncurses-dev python2"
+makedepends="ncurses-dev python3"
subpackages="$pkgname-doc"
options="!check" # no upstream/available test-suite
-source="http://hisham.hm/htop/releases/$pkgver/$pkgname-$pkgver.tar.gz"
+source="http://hisham.hm/htop/releases/$pkgver/$pkgname-$pkgver.tar.gz
+ fix-python-path.patch"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -33,4 +34,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="ec1335bf0e3e0387e5e50acbc508d0effad19c4bc1ac312419dc97b82901f4819600d6f87a91668f39d429536d17304d4b14634426a06bec2ecd09df24adc62e htop-2.2.0.tar.gz"
+sha512sums="ec1335bf0e3e0387e5e50acbc508d0effad19c4bc1ac312419dc97b82901f4819600d6f87a91668f39d429536d17304d4b14634426a06bec2ecd09df24adc62e htop-2.2.0.tar.gz
+f2eeafb7207ba14dc7577aa85618adb71fb689a42476d04c99f6be01e8c6ac77cd5ed8ee056b80ddb60c821e1d2c44ebcf4da40960c3b7e8bb3a0d64aad0fd9a fix-python-path.patch"
diff --git a/main/htop/fix-python-path.patch b/main/htop/fix-python-path.patch
new file mode 100644
index 0000000000..2bf3470516
--- /dev/null
+++ b/main/htop/fix-python-path.patch
@@ -0,0 +1,8 @@
+--- a/scripts/MakeHeader.py
++++ b/scripts/MakeHeader.py
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/python3
+ import os, sys, string, io
+ try:
+ from StringIO import StringIO