aboutsummaryrefslogtreecommitdiffstats
path: root/main/http-parser/0002-makefile-quote-variables.patch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-26 01:19:33 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-26 01:27:08 +0100
commit1b894fef00117044d640f9cbbd479c114973d3e8 (patch)
tree050f49499cba1fab6e71251f5cb67498671468df /main/http-parser/0002-makefile-quote-variables.patch
parent3daaac76560d7bf976ecdfe5bcc9b3efad0cbf61 (diff)
downloadaports-1b894fef00117044d640f9cbbd479c114973d3e8.tar.bz2
aports-1b894fef00117044d640f9cbbd479c114973d3e8.tar.xz
main/http-parser: move from community (needed for nodejs-lts)
Diffstat (limited to 'main/http-parser/0002-makefile-quote-variables.patch')
-rw-r--r--main/http-parser/0002-makefile-quote-variables.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/main/http-parser/0002-makefile-quote-variables.patch b/main/http-parser/0002-makefile-quote-variables.patch
new file mode 100644
index 0000000000..096ac6b6bd
--- /dev/null
+++ b/main/http-parser/0002-makefile-quote-variables.patch
@@ -0,0 +1,50 @@
+From 9bce473ba7417b45bfdb59d4151a8857dcfff4ad Mon Sep 17 00:00:00 2001
+From: hasufell <hasufell@hasufell.de>
+Date: Mon, 2 Nov 2015 16:27:06 +0100
+Subject: [PATCH 2/4] makefile: quote variables
+
+Make does not take care of this in make rules. If any of the variables
+DESTDIR, INCLUDEDIR or LIBDIR contain whitespaces, then the related
+install command will fail.
+
+This is even more important for the uninstall rule.
+---
+ Makefile | 18 +++++++++---------
+ 1 file changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 76153a0..8c4a9d7 100644
+--- a/Makefile
++++ b/Makefile
+@@ -123,19 +123,19 @@ tags: http_parser.c http_parser.h test.c
+ ctags $^
+
+ install: library
+- $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
+- $(INSTALL) -D $(SONAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+- ln -s $(LIBDIR)/$(SONAME) $(DESTDIR)$(LIBDIR)/libhttp_parser.$(SOEXT)
++ $(INSTALL) -D http_parser.h "$(DESTDIR)$(INCLUDEDIR)/http_parser.h"
++ $(INSTALL) -D $(SONAME) "$(DESTDIR)$(LIBDIR)/$(SONAME)"
++ ln -s $(LIBDIR)/$(SONAME) "$(DESTDIR)$(LIBDIR)/libhttp_parser.$(SOEXT)"
+
+ install-strip: library
+- $(INSTALL) -D http_parser.h $(DESTDIR)$(INCLUDEDIR)/http_parser.h
+- $(INSTALL) -D -s $(SONAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+- ln -s $(LIBDIR)/$(SONAME) $(DESTDIR)$(LIBDIR)/libhttp_parser.$(SOEXT)
++ $(INSTALL) -D http_parser.h "$(DESTDIR)$(INCLUDEDIR)/http_parser.h"
++ $(INSTALL) -D -s $(SONAME) "$(DESTDIR)$(LIBDIR)/$(SONAME)"
++ ln -s $(LIBDIR)/$(SONAME) "$(DESTDIR)$(LIBDIR)/libhttp_parser.$(SOEXT)"
+
+ uninstall:
+- rm $(DESTDIR)$(INCLUDEDIR)/http_parser.h
+- rm $(DESTDIR)$(LIBDIR)/$(SONAME)
+- rm $(DESTDIR)$(LIBDIR)/libhttp_parser.so
++ rm "$(DESTDIR)$(INCLUDEDIR)/http_parser.h"
++ rm "$(DESTDIR)$(LIBDIR)/$(SONAME)"
++ rm "$(DESTDIR)$(LIBDIR)/libhttp_parser.so"
+
+ clean:
+ rm -f *.o *.a tags test test_fast test_g \
+--
+2.6.1
+