aboutsummaryrefslogtreecommitdiffstats
path: root/main/iftop
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-15 11:08:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-15 11:25:42 +0000
commitec7cc3fea1209aae720efdf642c3ed4f8aca546e (patch)
treec3bb942281f592342d8867f0bed936ee2f5e46db /main/iftop
parent0ce3326d5598f65e9705bb0584e58776b9649494 (diff)
downloadaports-ec7cc3fea1209aae720efdf642c3ed4f8aca546e.tar.bz2
aports-ec7cc3fea1209aae720efdf642c3ed4f8aca546e.tar.xz
main/iftop: update config.sub
Diffstat (limited to 'main/iftop')
-rw-r--r--main/iftop/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/iftop/APKBUILD b/main/iftop/APKBUILD
index 26a8b0fd86..4d5aca4300 100644
--- a/main/iftop/APKBUILD
+++ b/main/iftop/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iftop
pkgver=0.17
-pkgrel=2
+pkgrel=3
pkgdesc="iftop does for network usage what top(1) does for CPU usage"
url="http://www.ex-parrot.com/~pdw/iftop/"
arch="all"
@@ -11,8 +11,14 @@ makedepends="libpcap-dev>=1 ncurses-dev"
subpackages="$pkgname-doc"
source="http://www.ex-parrot.com/~pdw/$pkgname/download/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/iftop-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,7 +29,7 @@ build() {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
}
md5sums="062bc8fb3856580319857326e0b8752d iftop-0.17.tar.gz"