aboutsummaryrefslogtreecommitdiffstats
path: root/main/igmpproxy
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-16 18:52:00 +0000
commitced1e02903a233c6ca2a36e816cea9fd6946f0ed (patch)
tree17f52ace253ef6a4baaf0d2b81cba0aaeaee6ee9 /main/igmpproxy
parent8bd4249e988a560cb63b28238f4ed10f46ee9a23 (diff)
downloadaports-ced1e02903a233c6ca2a36e816cea9fd6946f0ed.tar.bz2
aports-ced1e02903a233c6ca2a36e816cea9fd6946f0ed.tar.xz
[various]: update config.sub, and update apkbuild
Diffstat (limited to 'main/igmpproxy')
-rw-r--r--main/igmpproxy/APKBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/main/igmpproxy/APKBUILD b/main/igmpproxy/APKBUILD
index 792cb2f7eb..76c15d9345 100644
--- a/main/igmpproxy/APKBUILD
+++ b/main/igmpproxy/APKBUILD
@@ -13,8 +13,14 @@ install=
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
# our kernel have a patch that changes MAXVIFS
# note that this is ABI incompatible
@@ -30,6 +36,10 @@ build() {
--infodir=/usr/share/info \
|| return 1
make || return 1
+}
+
+package() {
+ cd "$_builddir"
make DESTDIR="$pkgdir" install
# install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
@@ -37,3 +47,5 @@ build() {
}
md5sums="c56f41ec195bc1fe016369bf74efc5a1 igmpproxy-0.1.tar.gz"
+sha256sums="ee18ff3d8c3ae3a29dccb7e5eedf332337330020168bd95a11cece8d7d7ee6ae igmpproxy-0.1.tar.gz"
+sha512sums="1a569814d8984610402313d8c4adb78ff362f82ae28c968a8ba0fb411e12a704d1b51b387111b51517ab8fb2e86952bbd196f27eccd311c11ce288fc6fa25ad4 igmpproxy-0.1.tar.gz"