aboutsummaryrefslogtreecommitdiffstats
path: root/main/iperf
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-14 03:02:59 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-14 03:04:05 +0200
commit9fa9be59f4bd883c619f42e1214de9fbdbffb1ae (patch)
tree6cfe3f4c50bb90c26869a5f0f408d9fea7db2e9b /main/iperf
parent1f684b76d9d9bbf6df7ad8f2e937bc4ede67440f (diff)
downloadaports-9fa9be59f4bd883c619f42e1214de9fbdbffb1ae.tar.bz2
aports-9fa9be59f4bd883c619f42e1214de9fbdbffb1ae.tar.xz
/main/iperf: upgrade to 3.1.3
Diffstat (limited to 'main/iperf')
-rw-r--r--main/iperf/1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch36
-rw-r--r--main/iperf/APKBUILD40
-rw-r--r--main/iperf/remove-pg-flags.patch28
3 files changed, 87 insertions, 17 deletions
diff --git a/main/iperf/1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch b/main/iperf/1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch
new file mode 100644
index 0000000000..4d53c4bd92
--- /dev/null
+++ b/main/iperf/1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch
@@ -0,0 +1,36 @@
+From 1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6 Mon Sep 17 00:00:00 2001
+From: Bernd Kuhls <bernd.kuhls@t-online.de>
+Date: Sat, 30 Jan 2016 19:23:20 +0100
+Subject: [PATCH] Fix build using musl libc
+
+Fixes https://github.com/esnet/iperf/issues/331
+---
+ src/cjson.h | 2 ++
+ src/timer.h | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/src/cjson.h b/src/cjson.h
+index d4449e6..7af19a9 100644
+--- a/src/cjson.h
++++ b/src/cjson.h
+@@ -23,6 +23,8 @@
+ #ifndef cJSON__h
+ #define cJSON__h
+
++#include <stdint.h>
++
+ #ifdef __cplusplus
+ extern "C"
+ {
+diff --git a/src/timer.h b/src/timer.h
+index 0f9c5eb..9b22b7f 100644
+--- a/src/timer.h
++++ b/src/timer.h
+@@ -30,6 +30,7 @@
+ #ifndef __TIMER_H
+ #define __TIMER_H
+
++#include <stdint.h>
+ #include <sys/time.h>
+
+ /* TimerClientData is an opaque value that tags along with a timer. The
diff --git a/main/iperf/APKBUILD b/main/iperf/APKBUILD
index cbb87f972f..07d5431a55 100644
--- a/main/iperf/APKBUILD
+++ b/main/iperf/APKBUILD
@@ -1,29 +1,29 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=iperf
-pkgver=2.0.5
-pkgrel=3
+pkgver=3.1.3
+pkgrel=0
pkgdesc="A tool to measure IP bandwidth using UDP or TCP"
-url="http://iperf.sourceforge.net/"
+url="https://github.com/esnet/iperf"
arch="all"
license="BSD"
depends=""
makedepends=""
install=""
subpackages="$pkgname-doc"
-source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+source="$pkgname-$pkgver.tar.gz::https://github.com/esnet/iperf/archive/$pkgver.tar.gz
iperf.initd
iperf.confd
+
+ 1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch
+ remove-pg-flags.patch
"
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- cd "$_builddir"
- update_config_sub || return 1
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,18 +36,24 @@ build() {
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install || return 1
install -D -m0755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname
install -D -m0644 "$srcdir"/$pkgname.confd "$pkgdir"/etc/conf.d/$pkgname
}
-md5sums="44b5536b67719f4250faed632a3cd016 iperf-2.0.5.tar.gz
+md5sums="7d9e550129d1ba68d4f49ea9dd412ada iperf-3.1.3.tar.gz
291084a99bc42217bf20a3f9f479e4d0 iperf.initd
-baf349898c6d08eaa3883d7e6802745c iperf.confd"
-sha256sums="636b4eff0431cea80667ea85a67ce4c68698760a9837e1e9d13096d20362265b iperf-2.0.5.tar.gz
+baf349898c6d08eaa3883d7e6802745c iperf.confd
+056442b6d4bef2a390f49124150fd4c9 1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch
+2bbaa32466ae3a3d7cf2c26d46d97324 remove-pg-flags.patch"
+sha256sums="e34cf60cffc80aa1322d2c3a9b81e662c2576d2b03e53ddf1079615634e6f553 iperf-3.1.3.tar.gz
b109c524d71a9da0db18c271b74238ef5f85b270d2f60dc6ae8f097a3342d00d iperf.initd
-2063bd3defe0e58d43741ed6067f3f5552e579385620d0e0f5aa2b8e96b21151 iperf.confd"
-sha512sums="da9a0c01dea2a9dd33aa130b11d938d5f44dd6c3ab27526b0a43df5bf2550fede04238a00b7d54037426afe90ac6d8c4f4ae6861aa170ca7835b6664c9d6537f iperf-2.0.5.tar.gz
+2063bd3defe0e58d43741ed6067f3f5552e579385620d0e0f5aa2b8e96b21151 iperf.confd
+3bf6329c14a30fd3ce7adaeafe5d95485111e73440fd1d91f8429e3af1c0bb63 1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch
+35131030c9384025dc511f3fe359a0845b09ed8dede5960a7e9308ad15fccc52 remove-pg-flags.patch"
+sha512sums="67795d9d5b4fc719b3fbbc2683cbe2777412bb7212282a50a378f5bb3793c3c17e278d22816fd9d289b2606ce97624d496ba236e3686ce1a31b9f1d6e6f474e9 iperf-3.1.3.tar.gz
339fb04b41cce11e8ea8694d95c13af9c88e0d1143356d913ec810c9b11efa27212d585b5dcc49cc2eb860a6d8bc557092c8659d7d5cfe532c5afdb36f8eedf8 iperf.initd
-fb5e155fff568a72488cc1511d30358835a48bcce309f8f46d040160932b4a4ccb85040c27c60dee477900a25bd34c50eac21d1d0bea984b40faa401be2ba7e8 iperf.confd"
+fb5e155fff568a72488cc1511d30358835a48bcce309f8f46d040160932b4a4ccb85040c27c60dee477900a25bd34c50eac21d1d0bea984b40faa401be2ba7e8 iperf.confd
+94a37158a1486442ef8f4a9bfb7f1fd02786dc5a3352a7249e2b5f0c910f0d2b951e40bdb94619aa8ca76ce8cda4c574a7fa85e12832c9fd684d074886aee7c7 1fe02385b60c9dcd8a04b8bd3ff5cff120ec35a6.patch
+81808862eecacdd7be658daa094385d7a57594281992b6b9b842cee676137d6990dce592b25e5db9fb80ea86628286ff7d234787d2939ef1f99820a361e1f3c6 remove-pg-flags.patch"
diff --git a/main/iperf/remove-pg-flags.patch b/main/iperf/remove-pg-flags.patch
new file mode 100644
index 0000000000..4d6482d3d8
--- /dev/null
+++ b/main/iperf/remove-pg-flags.patch
@@ -0,0 +1,28 @@
+--- ./src/Makefile.am.orig
++++ ./src/Makefile.am
+@@ -49,9 +49,9 @@
+ iperf3_profile_SOURCES = main.c \
+ $(libiperf_la_SOURCES)
+
+-iperf3_profile_CFLAGS = -pg -g
++iperf3_profile_CFLAGS = -g
+ iperf3_profile_LDADD = libiperf.la
+-iperf3_profile_LDFLAGS = -pg -g
++iperf3_profile_LDFLAGS = -g
+
+ # Specify the sources and various flags for the test cases
+ t_timer_SOURCES = t_timer.c
+--- ./src/Makefile.in.orig
++++ ./src/Makefile.in
+@@ -610,9 +610,9 @@
+ iperf3_profile_SOURCES = main.c \
+ $(libiperf_la_SOURCES)
+
+-iperf3_profile_CFLAGS = -pg -g
++iperf3_profile_CFLAGS = -g
+ iperf3_profile_LDADD = libiperf.la
+-iperf3_profile_LDFLAGS = -pg -g
++iperf3_profile_LDFLAGS = -g
+
+ # Specify the sources and various flags for the test cases
+ t_timer_SOURCES = t_timer.c