aboutsummaryrefslogtreecommitdiffstats
path: root/main/iproute2
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-06-27 23:03:10 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-06-27 23:04:11 +0200
commitf4ec0f7bd20cccc3b274f5aed1a3fd634987efe7 (patch)
tree7df679a25aaaa40910acbb09c2ca8fd51a184ac3 /main/iproute2
parented3867ce17f2c5612da25f237d247e3d563e3c36 (diff)
downloadaports-f4ec0f7bd20cccc3b274f5aed1a3fd634987efe7.tar.bz2
aports-f4ec0f7bd20cccc3b274f5aed1a3fd634987efe7.tar.xz
main/iproute2: fix install(1) invocation if libmnl isn't available
Diffstat (limited to 'main/iproute2')
-rw-r--r--main/iproute2/APKBUILD6
-rw-r--r--main/iproute2/fix-install-errors.patch40
2 files changed, 44 insertions, 2 deletions
diff --git a/main/iproute2/APKBUILD b/main/iproute2/APKBUILD
index 65dd99c6fc..9629753d25 100644
--- a/main/iproute2/APKBUILD
+++ b/main/iproute2/APKBUILD
@@ -10,7 +10,8 @@ depends=""
install="$pkgname.post-install"
makedepends="bison flex bash iptables-dev libelf-dev"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
-source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz"
+source="https://kernel.org/pub/linux/utils/net/iproute2/iproute2-$pkgver.tar.xz
+ fix-install-errors.patch"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -52,4 +53,5 @@ bashcomp() {
rmdir -p "$pkgdir"/usr/share 2>/dev/null || true
}
-sha512sums="ccd7fb70afd58f1fcd4e17c38a24607207da853c4d6118fda423efa6e51faad3ad03c4d6d58a579c40ef9c68aaf13b1c455e12b0c36e155712d3d4db3c2ff4b5 iproute2-4.17.0.tar.xz"
+sha512sums="ccd7fb70afd58f1fcd4e17c38a24607207da853c4d6118fda423efa6e51faad3ad03c4d6d58a579c40ef9c68aaf13b1c455e12b0c36e155712d3d4db3c2ff4b5 iproute2-4.17.0.tar.xz
+24fc2a901650e11f80bcaa82c839e70c21aafdf3c5b8a357d932d066a0b98ae2ec8379fc17a0a16a1b5b4fa5edc131179c10fc02e55d6101701df5a09966912c fix-install-errors.patch"
diff --git a/main/iproute2/fix-install-errors.patch b/main/iproute2/fix-install-errors.patch
new file mode 100644
index 0000000000..d514032b77
--- /dev/null
+++ b/main/iproute2/fix-install-errors.patch
@@ -0,0 +1,40 @@
+Without this patch the following error message shows up three times
+during `make install:`
+
+ install -m 0755 /home/travis/build/alpinelinux/aports/main/iproute2/pkg/iproute2/sbin
+ BusyBox v1.28.4 (2018-05-30 10:45:57 UTC) multi-call binary.
+ Usage: install [-cdDsp] [-o USER] [-g GRP] [-m MODE] [-t DIR] [SOURCE]... DEST
+ Copy files and set attributes
+ -c Just copy (default)
+ -d Create directories
+ -D Create leading target directories
+ -s Strip symbol table
+ -p Preserve date
+ -o USER Set ownership
+ -g GRP Set group ownership
+ -m MODE Set permissions
+ -t DIR Install to DIR
+ make[1]: *** [Makefile:25: install] Error 1
+
+diff -upr iproute2-4.17.0.orig/Makefile iproute2-4.17.0/Makefile
+--- iproute2-4.17.0.orig/Makefile 2018-06-27 22:58:35.818077991 +0200
++++ iproute2-4.17.0/Makefile 2018-06-27 23:00:33.118560603 +0200
+@@ -61,7 +61,17 @@ WFLAGS += -Wmissing-declarations -Wold-s
+ CFLAGS := $(WFLAGS) $(CCOPTS) -I../include -I../include/uapi $(DEFINES) $(CFLAGS)
+ YACCFLAGS = -d -t -v
+
+-SUBDIRS=lib ip tc bridge misc netem genl tipc devlink rdma man
++SUBDIRS=lib ip tc bridge misc netem genl man
++
++# The following subdirs require libmnl. If libmnl isn't installed
++# install(1) is called with invalid arguments when the install
++# target is invoked in those subdirs because $(TARGETS) is empty.
++#
++# To prevent these errors we only include the subdirs if libmnl is
++# actually available.
++ifeq ($(HAVE_MNL),y)
++SUBDIRS += tipc devlink rdma
++endif
+
+ LIBNETLINK=../lib/libutil.a ../lib/libnetlink.a
+ LDLIBS += $(LIBNETLINK)