aboutsummaryrefslogtreecommitdiffstats
path: root/main/lame
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2011-04-01 16:52:34 +0300
committerTimo Teräs <timo.teras@iki.fi>2011-04-01 16:52:47 +0300
commit77aff19e6d50d5443d646733229b5e149308a129 (patch)
treea51d0902f3d320ac6b6bc5a9540bfd16839efcab /main/lame
parentf37ccfd1a0dc134315f8e893653d55e3a4e402c0 (diff)
downloadaports-77aff19e6d50d5443d646733229b5e149308a129.tar.bz2
aports-77aff19e6d50d5443d646733229b5e149308a129.tar.xz
main/lame: fix PIC with new nasm
Diffstat (limited to 'main/lame')
-rw-r--r--main/lame/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/main/lame/APKBUILD b/main/lame/APKBUILD
index b27512a667..b79d7da754 100644
--- a/main/lame/APKBUILD
+++ b/main/lame/APKBUILD
@@ -2,7 +2,7 @@
pkgname=lame
pkgver=3.98.4
_ver=398-2
-pkgrel=1
+pkgrel=2
pkgdesc="An MP3 encoder and graphical frame analyzer"
url="http://lame.sourceforge.net/"
arch="all"
@@ -24,6 +24,9 @@ build() {
# fix for parallel builds
mkdir -p libmp3lame/i386/.libs
+ # fix for pic build with new nasm
+ sed -i -e 's/__OUTPUT_FORMAT__,elf/__OUTPUT_FORMAT__,elf32/g' libmp3lame/i386/nasm.h
+
# Fix for ffmpeg.
# https://bugs.gentoo.org/show_bug.cgi?id=265830
patch -p1 < ../lame-3.98.2-ffmpeg-0.5.patch || return 1
@@ -33,7 +36,8 @@ build() {
./configure --prefix=/usr \
--enable-nasm \
--disable-mp3x \
- --enable-shared
+ --enable-shared \
+ --with-pic
make || return 1
}