aboutsummaryrefslogtreecommitdiffstats
path: root/main/lftp/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-17 08:29:04 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-17 08:29:04 +0000
commit0f9935dbde2ee3ecea57f79095c4d17afb39a77c (patch)
tree4a467df7151f29fb0cc63c4239a3b037095ef032 /main/lftp/APKBUILD
parentd7ad83c5a4acb9916e03b6deb79f364e83108fff (diff)
downloadaports-0f9935dbde2ee3ecea57f79095c4d17afb39a77c.tar.bz2
aports-0f9935dbde2ee3ecea57f79095c4d17afb39a77c.tar.xz
main/lftp: properly fix musl build
The gnulib tests were ran in a wrong way. Filed issue upstream: https://github.com/lavv17/lftp/issues/59
Diffstat (limited to 'main/lftp/APKBUILD')
-rw-r--r--main/lftp/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/main/lftp/APKBUILD b/main/lftp/APKBUILD
index 75dfd02856..c4d095f463 100644
--- a/main/lftp/APKBUILD
+++ b/main/lftp/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=lftp
pkgver=4.4.15
-pkgrel=1
+pkgrel=2
pkgdesc="LFTP is sophisticated ftp/http client"
url="http://lftp.yar.ru/"
arch="all"
license="GPL"
depends=
-makedepends="gnutls-dev readline-dev ncurses-dev gettext-dev"
+makedepends="gnutls-dev readline-dev ncurses-dev gettext-dev autoconf automake
+ libtool"
subpackages="$pkgname-doc"
source="http://lftp.yar.ru/ftp/lftp-$pkgver.tar.xz
- musl-fix.patch"
+ 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -23,6 +24,8 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ libtoolize --force && aclocal -I m4 && autoconf \
+ && automake --add-missing || return 1
}
build() {
@@ -53,8 +56,8 @@ package() {
}
md5sums="f19cc0cea1d427aa2a952b27661b91e5 lftp-4.4.15.tar.xz
-696ee578b149914ad230190fba6b83d6 musl-fix.patch"
+91de52bcbda9490d62cea72be78ab72a 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
sha256sums="75f40b7ab438a7b295410eb3e1ec8460e36ad2d48785383a6fc9201905db6868 lftp-4.4.15.tar.xz
-8b85bfa39de217d8fb765ee9b8f26b4368fd9002a40e5b75dee466c3a59024cd musl-fix.patch"
+e50ae5f0db272a31146cc29909bd07a1b7c11c78dad6e9a51eb3ad4231b5c323 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"
sha512sums="1d828a7b2ff808a0ee78f51c265d58df677e67cec9b4744cbd3a34816aba324199202094fa4144665e8d64385df7e76a54c6dc415e9ff33e97adab2eb0edaf4e lftp-4.4.15.tar.xz
-e9fab08f570032ad6b006d05446d583441dc5a1c236343b8de89f31fad7df2f969cfe9f888c371acbf24c69b2c07e66d736105101739cc4753299feef7f372a4 musl-fix.patch"
+3f7e7958787c323b148415ba42d8748d27a515da2dbc62c087e778190806cf6f683900966c359829d3ba1a4d8d06a874d35c41316c89059b1c85806328f422cc 0001-run-the-gunlib-checks-with-same-compiler-as-when-bui.patch"