aboutsummaryrefslogtreecommitdiffstats
path: root/main/libbsd
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-10-12 01:40:13 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-10-12 01:40:44 +0000
commit63d3e50fb4bbcd669712439443b2ce058306efee (patch)
treeebb694794758a0e0e20fe575208ded90b300fe76 /main/libbsd
parent1c661281637c2f8fc02abbf16f3c0ab7e01a5363 (diff)
downloadaports-63d3e50fb4bbcd669712439443b2ce058306efee.tar.bz2
aports-63d3e50fb4bbcd669712439443b2ce058306efee.tar.xz
main/libbsd: upgrade to 0.8.6
- drop patch 0003-Fix-build-breaks-due-to-missing-a.out.h.patch, carried upstream
Diffstat (limited to 'main/libbsd')
-rw-r--r--main/libbsd/0003-Fix-build-breaks-due-to-missing-a.out.h.patch130
-rw-r--r--main/libbsd/APKBUILD10
2 files changed, 4 insertions, 136 deletions
diff --git a/main/libbsd/0003-Fix-build-breaks-due-to-missing-a.out.h.patch b/main/libbsd/0003-Fix-build-breaks-due-to-missing-a.out.h.patch
deleted file mode 100644
index 176d940fc4..0000000000
--- a/main/libbsd/0003-Fix-build-breaks-due-to-missing-a.out.h.patch
+++ /dev/null
@@ -1,130 +0,0 @@
-From a1b93c25311834f2f411e9bfe2e616899ba2122d Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 6 Nov 2016 10:23:55 -0800
-Subject: [PATCH 3/3] Fix build breaks due to missing a.out.h
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
-Upstream-Status: Pending
-
- include/bsd/nlist.h | 1 -
- include/bsd/nlist.h => src/local-aout.h | 47 ++++++++++++++++++++++-----------
- src/nlist.c | 9 +++++++
- 3 files changed, 41 insertions(+), 16 deletions(-)
- copy include/bsd/nlist.h => src/local-aout.h (63%)
-
-diff --git a/include/bsd/nlist.h b/include/bsd/nlist.h
-index 0389ab7..9c7e3d8 100644
---- a/include/bsd/nlist.h
-+++ b/include/bsd/nlist.h
-@@ -28,7 +28,6 @@
- #define LIBBSD_NLIST_H
-
- #include <sys/cdefs.h>
--#include <a.out.h>
-
- /* __BEGIN_DECLS */
- #ifdef __cplusplus
-diff --git a/include/bsd/nlist.h b/src/local-aout.h
-similarity index 63%
-copy from include/bsd/nlist.h
-copy to src/local-aout.h
-index 0389ab7..2adb93e 100644
---- a/include/bsd/nlist.h
-+++ b/src/local-aout.h
-@@ -1,5 +1,5 @@
- /*
-- * Copyright © 2009 Guillem Jover <guillem@hadrons.org>
-+ * Copyright © 2016 Khem Raj <raj.khem@gmail.com>
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
-@@ -24,20 +24,37 @@
- * ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
--#ifndef LIBBSD_NLIST_H
--#define LIBBSD_NLIST_H
-+#ifndef LIBBSD_LOCAL_AOUT_H
-+#define LIBBSD_LOCAL_AOUT_H
-
--#include <sys/cdefs.h>
--#include <a.out.h>
-+#define N_UNDF 0
-+#define N_ABS 2
-+#define N_TEXT 4
-+#define N_DATA 6
-+#define N_BSS 8
-+#define N_FN 15
-+#define N_EXT 1
-+#define N_TYPE 036
-+#define N_STAB 0340
-+#define N_INDR 0xa
-+#define N_SETA 0x14 /* Absolute set element symbol. */
-+#define N_SETT 0x16 /* Text set element symbol. */
-+#define N_SETD 0x18 /* Data set element symbol. */
-+#define N_SETB 0x1A /* Bss set element symbol. */
-+#define N_SETV 0x1C /* Pointer to set vector in data area. */
-
--/* __BEGIN_DECLS */
--#ifdef __cplusplus
--extern "C" {
--#endif
--extern int nlist(const char *filename, struct nlist *list);
--#ifdef __cplusplus
--}
--#endif
--/* __END_DECLS */
-+struct nlist
-+{
-+ union
-+ {
-+ char *n_name;
-+ struct nlist *n_next;
-+ long n_strx;
-+ } n_un;
-+ unsigned char n_type;
-+ char n_other;
-+ short n_desc;
-+ unsigned long n_value;
-+};
-
--#endif
-+#endif /* LIBBSD_LOCAL_AOUT_H */
-diff --git a/src/nlist.c b/src/nlist.c
-index 0cffe55..625d310 100644
---- a/src/nlist.c
-+++ b/src/nlist.c
-@@ -40,7 +40,11 @@ static char sccsid[] = "@(#)nlist.c 8.1 (Berkeley) 6/4/93";
-
- #include <errno.h>
- #include <fcntl.h>
-+#ifdef __GLIBC__
- #include <a.out.h>
-+#else
-+#define __NO_A_OUT_SUPPORT
-+#endif
- #include <stdio.h>
- #include <string.h>
- #include <unistd.h>
-@@ -48,12 +52,17 @@ static char sccsid[] = "@(#)nlist.c 8.1 (Berkeley) 6/4/93";
- #if !defined(__NO_A_OUT_SUPPORT)
- #define _NLIST_DO_AOUT
- #endif
-+
- #define _NLIST_DO_ELF
-
- #ifdef _NLIST_DO_ELF
- #include "local-elf.h"
- #endif
-
-+#ifdef _NLIST_DO_ELF
-+#include "local-aout.h"
-+#endif
-+
- #define SIZE_T_MAX 0xffffffffU
-
- #ifdef _NLIST_DO_AOUT
---
-2.10.2
-
diff --git a/main/libbsd/APKBUILD b/main/libbsd/APKBUILD
index 6d9bde8735..1254d88eaf 100644
--- a/main/libbsd/APKBUILD
+++ b/main/libbsd/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libbsd
-pkgver=0.8.3
-pkgrel=4
+pkgver=0.8.6
+pkgrel=0
pkgdesc="commonly-used BSD functions not implemented by all libcs"
url="http://libbsd.freedesktop.org/"
arch="all"
@@ -14,7 +14,6 @@ makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="http://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
- 0003-Fix-build-breaks-due-to-missing-a.out.h.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -44,6 +43,5 @@ package() {
install || return 1
}
-sha512sums="155b895d6bd62b180718d65a2cda7484946c492d52735a57b51005705dfe4528b6a72e8745acea47b01fe68e3bbbe3c036c5e9998a8d06fc79efe2b96a04767f libbsd-0.8.3.tar.xz
-4ef5d664f04af21da17c5ac9eed6fec4c0c7d06ff3af70e93bfdfdf926c7473954649e315158ec8f90cef93f82524431fa4fbc60374d20007f1234d6afe9edcd 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
-64b68497c9a638d43f90f148d206d59afabec0a62e39522200f72f9ba27529809c6e578ad670681424b2b940ba32a9fab6c526487fd9c6863e0c9a15749bd80a 0003-Fix-build-breaks-due-to-missing-a.out.h.patch"
+sha512sums="ece01ced324f840c2cee6321c7dcf97ff123d55ea9f203c1ce35e1b46643dc7b34ef6dc6c8d128252b36848624850b40823411cc96b99a66a401eb1e9d8cea6b libbsd-0.8.6.tar.xz
+4ef5d664f04af21da17c5ac9eed6fec4c0c7d06ff3af70e93bfdfdf926c7473954649e315158ec8f90cef93f82524431fa4fbc60374d20007f1234d6afe9edcd 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch"