aboutsummaryrefslogtreecommitdiffstats
path: root/main/libbsd
diff options
context:
space:
mode:
authorTuan M. Hoang <tmhoang@flatglobe.org>2017-04-20 14:22:32 -0400
committerJakub Jirutka <jakub@jirutka.cz>2017-04-21 03:34:50 +0200
commit91f51130be8275df4f5cb1c9dd4ff66d7720e856 (patch)
treef0499ead4046ebe6622958bab98cffd72aae1f0d /main/libbsd
parent96226b0e2153d993d7781383ea762d5956cb810c (diff)
downloadaports-91f51130be8275df4f5cb1c9dd4ff66d7720e856.tar.bz2
aports-91f51130be8275df4f5cb1c9dd4ff66d7720e856.tar.xz
main/libbsd: fix build on s390x
Diffstat (limited to 'main/libbsd')
-rw-r--r--main/libbsd/APKBUILD6
-rw-r--r--main/libbsd/fix-build-with-musl-on-ppc64le-s390x.patch (renamed from main/libbsd/fix-build-with-musl-on-ppc64le.patch)11
2 files changed, 9 insertions, 8 deletions
diff --git a/main/libbsd/APKBUILD b/main/libbsd/APKBUILD
index aaa8f67ff5..140f0adfec 100644
--- a/main/libbsd/APKBUILD
+++ b/main/libbsd/APKBUILD
@@ -14,9 +14,9 @@ makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="http://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
musl-fixes.patch
- fix-build-with-musl-on-ppc64le.patch"
-
+ fix-build-with-musl-on-ppc64le-s390x.patch"
builddir="$srcdir/$pkgname-$pkgver"
+
prepare() {
default_prepare || return 1
@@ -45,4 +45,4 @@ package() {
sha512sums="155b895d6bd62b180718d65a2cda7484946c492d52735a57b51005705dfe4528b6a72e8745acea47b01fe68e3bbbe3c036c5e9998a8d06fc79efe2b96a04767f libbsd-0.8.3.tar.xz
032b8de7abfe6ffec80957db05fcb02b2cec74f26ecc99ef20d2a314efd0dfd88486e31bd33dd7460ac85b48acdab3ba849cd96bdd0884cd5667e7a43ab30c3a musl-fixes.patch
-6e9e182bc45acde46aedd7696783636a6f9901e01436d26ee22104d39adae13b6bb0231b02be0db1a461faa3bc611c16296f37f5ab5f365dd3719daaebb9863a fix-build-with-musl-on-ppc64le.patch"
+19d7a11fae5b2927eafa320cb683b8645df2cb04f8ea05934543351b07eaa033d3cabe90687048e4a5a2e7efdddab409061fcddf0dea8cb769bad04670659d2e fix-build-with-musl-on-ppc64le-s390x.patch"
diff --git a/main/libbsd/fix-build-with-musl-on-ppc64le.patch b/main/libbsd/fix-build-with-musl-on-ppc64le-s390x.patch
index 0385f38175..0216ef5cf7 100644
--- a/main/libbsd/fix-build-with-musl-on-ppc64le.patch
+++ b/main/libbsd/fix-build-with-musl-on-ppc64le-s390x.patch
@@ -5,18 +5,16 @@ in Ubuntu ppc64le it is provided by glibc (a.out.h), but in Alpine ppc64le it is
available.
A workaround for this problem is to define the types that are being used
-by libbsd instead of including the invalid header for ppc64le.
+by libbsd instead of including the invalid header for ppc64le and s390x.
===
--- libbsd-0.8.3.orig/src/nlist.c
+++ libbsd-0.8.3/src/nlist.c
-@@ -40,7 +40,48 @@
+@@ -40,7 +40,49 @@ static char sccsid[] = "@(#)nlist.c 8.1 (Berkeley) 6/4/93";
#include <errno.h>
#include <fcntl.h>
+
-+#ifndef __powerpc64__
- #include <linux/a.out.h>
-+#else
++#if defined(__powerpc64__) || defined(__s390x__)
+// Copied from a.out.h, because it is not available on ppc64le with musl
+struct nlist
+{
@@ -53,6 +51,9 @@ by libbsd instead of including the invalid header for ppc64le.
+#define N_EXT 1
+#define N_STAB 0340
+
++#else
+ #include <linux/a.out.h>
++
+#endif
+
#include <stdio.h>