aboutsummaryrefslogtreecommitdiffstats
path: root/main/libbsd
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 13:31:15 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 13:52:44 +0000
commit9af45942aa6dbc7e70666270163d894fb3dc9b3a (patch)
tree262c7a65c65fba23d657ab016253559a44f2f6a6 /main/libbsd
parentb7f2ea5d89f2ad3788af9bb7cbc4e01dbaa2ed06 (diff)
downloadaports-9af45942aa6dbc7e70666270163d894fb3dc9b3a.tar.bz2
aports-9af45942aa6dbc7e70666270163d894fb3dc9b3a.tar.xz
main/libbsd: fix musl build
Diffstat (limited to 'main/libbsd')
-rw-r--r--main/libbsd/APKBUILD22
-rw-r--r--main/libbsd/musl-fix-headers.patch25
2 files changed, 40 insertions, 7 deletions
diff --git a/main/libbsd/APKBUILD b/main/libbsd/APKBUILD
index d6555d451c..3e82f78b39 100644
--- a/main/libbsd/APKBUILD
+++ b/main/libbsd/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libbsd
pkgver=0.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="commonly-used BSD functions not implemented by all libcs"
url="http://libbsd.freedesktop.org/"
arch="all"
@@ -13,13 +13,18 @@ makedepends="$depends_dev autoconf automake libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://libbsd.freedesktop.org/releases/libbsd-$pkgver.tar.xz
- Revert_Force_setproctitle_into_.init_array_section.patch"
+ Revert_Force_setproctitle_into_.init_array_section.patch
+ musl-fix-headers.patch
+ "
_builddir="$srcdir"/libbsd-$pkgver
prepare() {
cd "$_builddir"
- patch -p1 -i "$srcdir"/Revert_Force_setproctitle_into_.init_array_section.patch \
- || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
autoreconf -fi || return 1
}
@@ -44,8 +49,11 @@ package() {
}
md5sums="f6c75f0a9818e323a589bcbd560a0eb4 libbsd-0.6.0.tar.xz
-628a86066f8a1222c7ffee5aa3d488ef Revert_Force_setproctitle_into_.init_array_section.patch"
+628a86066f8a1222c7ffee5aa3d488ef Revert_Force_setproctitle_into_.init_array_section.patch
+712fca9c718f8b0f4d664c214072d6b3 musl-fix-headers.patch"
sha256sums="9e8f34ffa9c8579c87965a55a82d8ac37a1dc64858f717b7c49452ade277cc62 libbsd-0.6.0.tar.xz
-a4497defcc14d04e407130931ed89c6b9e5e79c684884291cc080c6e90c82777 Revert_Force_setproctitle_into_.init_array_section.patch"
+a4497defcc14d04e407130931ed89c6b9e5e79c684884291cc080c6e90c82777 Revert_Force_setproctitle_into_.init_array_section.patch
+3082d5f47c6d895dc3546d517ba7d541602872f00d5b39852a0b28b3d74ce954 musl-fix-headers.patch"
sha512sums="d750ead28e76938ab8d9c5575c1c87bcf275754f9f82b19d647f522bfaf07e5a85dc47ed5faae093994e5456be806fdebb55eeeed74efff3c950dfb6142e2b5c libbsd-0.6.0.tar.xz
-52d3e69a2589dc299bcc5ca99bcf595d054be4c8b6b2ce4101d7657a54fecc4bc843b4439f0c9b582266559288220b342f926e700e7ae7e91bf29f0ae30d707f Revert_Force_setproctitle_into_.init_array_section.patch"
+52d3e69a2589dc299bcc5ca99bcf595d054be4c8b6b2ce4101d7657a54fecc4bc843b4439f0c9b582266559288220b342f926e700e7ae7e91bf29f0ae30d707f Revert_Force_setproctitle_into_.init_array_section.patch
+87a4337108776cf8ff05be5938b3c8a548a4dd5625ae8e4afbab54c4c06af287188a81213633540a82c07e90b028b616f30934b02e8ab7485efa0ae0afdf20ee musl-fix-headers.patch"
diff --git a/main/libbsd/musl-fix-headers.patch b/main/libbsd/musl-fix-headers.patch
new file mode 100644
index 0000000000..0556884e71
--- /dev/null
+++ b/main/libbsd/musl-fix-headers.patch
@@ -0,0 +1,25 @@
+--- libbsd-0.6.0.orig/src/flopen.c
++++ libbsd-0.6.0/src/flopen.c
+@@ -32,6 +32,7 @@
+ #include <sys/stat.h>
+
+ #include <errno.h>
++#include <fcntl.h>
+ #include <stdarg.h>
+ #include <unistd.h>
+ #include <libutil.h>
+--- libbsd-0.6.0.orig/src/nlist.c
++++ libbsd-0.6.0/src/nlist.c
+@@ -37,10 +37,11 @@
+ #include <sys/stat.h>
+ #include <sys/file.h>
+ #include <arpa/inet.h>
++#include <linux/a.out.h>
+
+ #include <errno.h>
+-#include <a.out.h>
+ #include <stdio.h>
++#include <fcntl.h>
+ #include <string.h>
+ #include <unistd.h>
+