aboutsummaryrefslogtreecommitdiffstats
path: root/main/libbsd
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-10 20:58:42 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-16 17:17:18 +0000
commitb25bff96562e1d427843e29f8de640862cac2681 (patch)
tree847bf448fa0e9d4c6d987f873da7d652232f6bc4 /main/libbsd
parentcdca45021830765ad71e58af7ed31f42d1d3d644 (diff)
downloadaports-b25bff96562e1d427843e29f8de640862cac2681.tar.bz2
aports-b25bff96562e1d427843e29f8de640862cac2681.tar.xz
main/libbsd: modernise, add check
Diffstat (limited to 'main/libbsd')
-rw-r--r--main/libbsd/APKBUILD22
-rw-r--r--main/libbsd/disable-fpurge-test.patch10
2 files changed, 24 insertions, 8 deletions
diff --git a/main/libbsd/APKBUILD b/main/libbsd/APKBUILD
index 2600ebdfb0..ceaba7ef91 100644
--- a/main/libbsd/APKBUILD
+++ b/main/libbsd/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=libbsd
pkgver=0.8.6
-pkgrel=1
+pkgrel=2
pkgdesc="commonly-used BSD functions not implemented by all libcs"
url="https://libbsd.freedesktop.org/"
arch="all"
@@ -14,14 +14,15 @@ makedepends="$depends_dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc"
source="https://libbsd.freedesktop.org/releases/$pkgname-$pkgver.tar.xz
0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
+ disable-fpurge-test.patch
"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
cd "$builddir"
- autoreconf -fi || return 1
+ autoreconf -fi
}
build() {
@@ -33,15 +34,20 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {
make DESTDIR="$pkgdir" -C "$builddir" \
- install || return 1
+ install
}
sha512sums="ece01ced324f840c2cee6321c7dcf97ff123d55ea9f203c1ce35e1b46643dc7b34ef6dc6c8d128252b36848624850b40823411cc96b99a66a401eb1e9d8cea6b libbsd-0.8.6.tar.xz
-4ef5d664f04af21da17c5ac9eed6fec4c0c7d06ff3af70e93bfdfdf926c7473954649e315158ec8f90cef93f82524431fa4fbc60374d20007f1234d6afe9edcd 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch"
+4ef5d664f04af21da17c5ac9eed6fec4c0c7d06ff3af70e93bfdfdf926c7473954649e315158ec8f90cef93f82524431fa4fbc60374d20007f1234d6afe9edcd 0001-Replace-__BEGIN_DECLS-and-__END_DECLS.patch
+34ab57a9b67c0d6035312dff78e6dd0d1c48442c6a1b6e769b6ebb6dccb0dac80ccc2c309724e39c097cdac944bdbd9522582f93f2567da8c6615990e2d0238b disable-fpurge-test.patch"
diff --git a/main/libbsd/disable-fpurge-test.patch b/main/libbsd/disable-fpurge-test.patch
new file mode 100644
index 0000000000..2a1950b123
--- /dev/null
+++ b/main/libbsd/disable-fpurge-test.patch
@@ -0,0 +1,10 @@
+--- libbsd-0.8.3/test/Makefile.am.old 2017-08-17 02:42:30.045825258 +0000
++++ libbsd-0.8.3/test/Makefile.am 2017-08-17 03:49:17.928202106 +0000
+@@ -37,7 +37,6 @@
+ humanize \
+ fgetln \
+ fparseln \
+- fpurge \
+ md5 \
+ proctitle-init \
+ strmode \