aboutsummaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-09-09 06:30:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-09-09 06:31:31 +0000
commitef92ec9cb4a5eb8ffc3a352cf2dec7e7e8160a8b (patch)
tree104c8a04ab90b03c5ec3eeff5d31b22f7de14b29 /main/libc0.9.32
parent41b26cba46c93dc763d69033c700be5f89a750ea (diff)
downloadaports-ef92ec9cb4a5eb8ffc3a352cf2dec7e7e8160a8b.tar.bz2
aports-ef92ec9cb4a5eb8ffc3a352cf2dec7e7e8160a8b.tar.xz
main/libc0.9.32: fix static linking
solves issue when linking static apk-tools
Diffstat (limited to 'main/libc0.9.32')
-rw-r--r--main/libc0.9.32/APKBUILD4
-rw-r--r--main/libc0.9.32/ld-tls.patch16
2 files changed, 19 insertions, 1 deletions
diff --git a/main/libc0.9.32/APKBUILD b/main/libc0.9.32/APKBUILD
index 2acccb9a88..11843bdfc1 100644
--- a/main/libc0.9.32/APKBUILD
+++ b/main/libc0.9.32/APKBUILD
@@ -3,7 +3,7 @@ _abiver=0.9.32
pkgname=libc$_abiver
_gitver=1008060645
pkgver=${_abiver}_alpha0_git$_gitver
-pkgrel=3
+pkgrel=4
pkgdesc="C library for developing embedded Linux systems"
url=http://uclibc.org
license="LGPL-2"
@@ -24,6 +24,7 @@ source="http://build.alpinelinux.org:8010/distfiles/$_snapfile
0001-netdb-increase-line-size-for-etc-services.patch
0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
getproto.patch
+ ld-tls.patch
uclibcconfig.x86
uclibcconfig.i486
"
@@ -112,5 +113,6 @@ d351ca4e5c33f4a7a60d4f1d754db5c4 0001-config-parser-fix-memory-corruption.patch
39ac96d750ad058030f917912bfea466 0001-netdb-increase-line-size-for-etc-services.patch
9dd8192227f54d6d3ccb49dc54137ff3 0001-create-DEVEL_PREFIX-MULTILIB_DIR-dir-rather-than-DEV.patch
18afaad25c578bfbe1c7ddb0bea1228a getproto.patch
+b769ffe8e6df01328fc6afb4b50da1cd ld-tls.patch
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.x86
e2eb3bb00a0fe4d6f3d5b5c56b027bab uclibcconfig.i486"
diff --git a/main/libc0.9.32/ld-tls.patch b/main/libc0.9.32/ld-tls.patch
new file mode 100644
index 0000000000..057191c57e
--- /dev/null
+++ b/main/libc0.9.32/ld-tls.patch
@@ -0,0 +1,16 @@
+diff --git a/libpthread/nptl/Makefile.in b/libpthread/nptl/Makefile.in
+index 99a726a..3e9676a 100644
+--- a/libpthread/nptl/Makefile.in
++++ b/libpthread/nptl/Makefile.in
+@@ -48,9 +48,9 @@ libc-shared-routines-y := $(addprefix $(libpthread_OUT)/,$(libc-shared-routines-
+ libc-static-routines-y := $(addprefix $(libpthread_OUT)/,$(libc-static-routines-y:.c=.o))
+ libc-shared-y += $(libc-shared-routines-y) $(libpthread_libc_OBJS:.o=.oS)
+ ifeq ($(DOPIC),y)
+-libc-static-y += $(libc-static-routines-y:.o=.os) $(libpthread_libc_a_OBJS:.o=.os) # $(libpthread_ld_tls_COBJ:.o=.os)
++libc-static-y += $(libc-static-routines-y:.o=.os) $(libpthread_libc_a_OBJS:.o=.os) $(libpthread_ld_tls_COBJ:.o=.os)
+ else
+-libc-static-y += $(libc-static-routines-y) $(libpthread_libc_a_OBJS) # $(libpthread_ld_tls_COBJ)
++libc-static-y += $(libc-static-routines-y) $(libpthread_libc_a_OBJS) $(libpthread_ld_tls_COBJ)
+ endif
+
+ librt-pt-routines-y := $(patsubst %.c,$(libpthread_pthread_OUT)/%.o,$(filter-out $(notdir $(libpthread_librt_OBJS:.o=.c)), $(librt-pt-routines-y)))