aboutsummaryrefslogtreecommitdiffstats
path: root/main/libidn
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-01 16:33:23 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-05 07:10:08 +0000
commitd0482455bd58af2ecd03a0135a2116b957fa8465 (patch)
treee81237f586417bdac750b88153548e63e8a59f31 /main/libidn
parent5306a6f8e693cc789338fce56c3ef23f59220fb5 (diff)
downloadaports-d0482455bd58af2ecd03a0135a2116b957fa8465.tar.bz2
aports-d0482455bd58af2ecd03a0135a2116b957fa8465.tar.xz
main/libidn: upgrade to 1.34
Diffstat (limited to 'main/libidn')
-rw-r--r--main/libidn/APKBUILD16
-rw-r--r--main/libidn/localename-test-fix.patch23
2 files changed, 18 insertions, 21 deletions
diff --git a/main/libidn/APKBUILD b/main/libidn/APKBUILD
index b83aa9330a..95d3572f32 100644
--- a/main/libidn/APKBUILD
+++ b/main/libidn/APKBUILD
@@ -1,10 +1,10 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libidn
-pkgver=1.33
-pkgrel=1
-pkgdesc="An encode and decode library for internationalized domain names"
-url="https://www.gnu.org/software/libidn/"
+pkgver=1.34
+pkgrel=0
+pkgdesc="Encode/Decode library for internationalized domain names"
+url="https://www.gnu.org/software/libidn"
arch="all"
license="GPL"
depends=
@@ -13,9 +13,7 @@ checkdepends="diffutils"
install=
subpackages="$pkgname-doc $pkgname-dev"
source="http://ftp.gnu.org/gnu/libidn/$pkgname-$pkgver.tar.gz
- localename-test-fix.patch
- "
-
+ localename-test-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
@@ -49,5 +47,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="38dd459eaeda0c9e3cc2d24d967113515a499747550a2a9157f32357def90d71a3a3b52398e96a44a28cd5948dc353b0473c4ff0453a69720191c4cb49cac2c6 libidn-1.33.tar.gz
-8251a6543a93db357181121d2f3895dd15d47b97e7c6b0004b1534f0479f8b08c380d184cb024dde9a158b967fad0643ea2a793e88bf90f07f3e67146ebab190 localename-test-fix.patch"
+sha512sums="1a9b5f2554d3953591b92010fa0fdedc438ca8bc31d2bc06c621eb5d423e81656607f09ac75bb02e1a5420459f69e82b5fb82987afa50db69793f9cd7a08365a libidn-1.34.tar.gz
+c37f9e318ab1f1e44a75074395bd8a93429265bdd3ccc6d7eae0f78beff53ff8ebac531a072d1859053ef517c7a1a6c1bf1b1f579d6dfc183df4cd016be4f825 localename-test-fix.patch"
diff --git a/main/libidn/localename-test-fix.patch b/main/libidn/localename-test-fix.patch
index a2c4564a17..8debe39386 100644
--- a/main/libidn/localename-test-fix.patch
+++ b/main/libidn/localename-test-fix.patch
@@ -1,34 +1,33 @@
---- libidn-1.33/lib/gltests/localename.c.old 2016-12-31 13:54:43.000000000 +0000
-+++ libidn-1.33/lib/gltests/localename.c 2017-07-30 16:40:47.098541270 +0000
+--- a/lib/gltests/localename.c 2018-02-03 19:27:45.000000000 +0000
++++ b/lib/gltests/localename.c 2018-04-01 15:54:44.383612550 +0000
@@ -40,7 +40,7 @@
# if defined __APPLE__ && defined __MACH__
# include <xlocale.h>
# endif
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
+-# if (__GLIBC__ >= 2 && !defined __UCLIBC__) || defined __CYGWIN__
+# if defined __linux__
# include <langinfo.h>
# endif
# if !defined IN_LIBINTL
-@@ -2692,16 +2692,19 @@
+@@ -2692,16 +2692,19 @@ gl_locale_name_thread_unsafe (int catego
locale_t thread_locale = uselocale (NULL);
if (thread_locale != LC_GLOBAL_LOCALE)
{
--# if __GLIBC__ >= 2 && !defined __UCLIBC__
-+# if defined(_NL_LOCALE_NAME)
-+ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
-+# if __GLIBC__ >= 2 && !defined __UCLIBC__
++# if defined(_NL_LOCALE_NAME)
++ const char *name = nl_langinfo(_NL_LOCALE_NAME(category));
+ # if __GLIBC__ >= 2 && !defined __UCLIBC__
/* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
glibc < 2.12.
- See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
+ See <https://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
- const char *name =
- nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
-+ if (name[0] == '\0')
++ if (name[0] == '\0')
+ name = nl_langinfo (_NL_ITEM ((category), _NL_ITEM_INDEX (-1)));
if (name[0] == '\0')
/* Fallback code for glibc < 2.4, which did not implement
nl_langinfo (_NL_LOCALE_NAME (category)). */
name = thread_locale->__names[category];
-+# endif
++# endif
return name;
- # elif defined __FreeBSD__ || (defined __APPLE__ && defined __MACH__)
+ # elif (defined __FreeBSD__ || defined __DragonFly__) || (defined __APPLE__ && defined __MACH__)
/* FreeBSD, Mac OS X */