aboutsummaryrefslogtreecommitdiffstats
path: root/main/libowfat/APKBUILD
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-10-24 19:47:39 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-10-24 19:50:07 +0200
commit14eb9cf91a5102b5d0d42b5d42ce1368589bd340 (patch)
tree7b9d1f95d17f629701fd99cbb1cc236e33901b8d /main/libowfat/APKBUILD
parent9bbcaaebbffeb2b78d9cd4434027d0571723c82f (diff)
downloadaports-14eb9cf91a5102b5d0d42b5d42ce1368589bd340.tar.bz2
aports-14eb9cf91a5102b5d0d42b5d42ce1368589bd340.tar.xz
main/libowfat: upgrade to 0.31
Diffstat (limited to 'main/libowfat/APKBUILD')
-rw-r--r--main/libowfat/APKBUILD37
1 files changed, 19 insertions, 18 deletions
diff --git a/main/libowfat/APKBUILD b/main/libowfat/APKBUILD
index 7ac2932f8b..e24489e728 100644
--- a/main/libowfat/APKBUILD
+++ b/main/libowfat/APKBUILD
@@ -1,34 +1,35 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net"
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libowfat
-pkgver=0.28
-pkgrel=1
-pkgdesc="reimplementation of libdjb"
+pkgver=0.31
+pkgrel=0
+pkgdesc="Reimplementation of libdjbr"
url="http://www.fefe.de/libowfat/"
arch="all"
license="GPL"
-depends=
-makedepends=
-install=
+depends=""
+makedepends=""
+install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="http://dl.fefe.de/libowfat-$pkgver.tar.bz2"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
-}
+source="https://www.fefe.de/$pkgname/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$_builddir"
- make || return 1
+ cd "$builddir"
+ make CFLAGS="-I. ${CFLAGS}" || return 1
}
package() {
- cd "$_builddir"
- make prefix="$pkgdir"/usr MAN3DIR="$pkgdir"/usr/share/man/man3 install
+ cd "$builddir"
+ make prefix="$pkgdir"/usr \
+ MAN3DIR="$pkgdir"/usr/share/man/man3 \
+ install || return 1
+
# buffer manpage conflicts with openssl
mv "$pkgdir"/usr/share/man/man3/buffer.3 \
"$pkgdir"/usr/share/man/man3/owfatbuffer.3
}
-md5sums="6bbee9a86506419657d87123b7a6f2c1 libowfat-0.28.tar.bz2"
+md5sums="120798fab86cfd72dc6b12284d248dd0 libowfat-0.31.tar.xz"
+sha256sums="d1e4ac1cfccbb7dc51d77d96398e6302d229ba7538158826c84cb4254c7e8a12 libowfat-0.31.tar.xz"
+sha512sums="b3ce973d6edc501ddaa6caa84dc3b74e3e31ced92e4f707038858cd36c977863251a7eaeababdad34ffe6b8ad13c9702118464f6f9fd827e05f6fbc5004408b5 libowfat-0.31.tar.xz"