aboutsummaryrefslogtreecommitdiffstats
path: root/main/libproxy
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-23 16:05:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-23 16:05:30 +0000
commit1febde356b017cfb19c87e59432bc956c2c76e52 (patch)
tree45600473d1e4d22ed9986ce2b887958b97e209ff /main/libproxy
parenta164cfe47f66d25186ee9d0095687ab2eb29a06e (diff)
downloadaports-1febde356b017cfb19c87e59432bc956c2c76e52.tar.bz2
aports-1febde356b017cfb19c87e59432bc956c2c76e52.tar.xz
main/libproxy: new aport
needed by glib-networking
Diffstat (limited to 'main/libproxy')
-rw-r--r--main/libproxy/APKBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/main/libproxy/APKBUILD b/main/libproxy/APKBUILD
new file mode 100644
index 0000000000..06e0bf9204
--- /dev/null
+++ b/main/libproxy/APKBUILD
@@ -0,0 +1,62 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libproxy
+pkgver=0.4.6
+pkgrel=0
+pkgdesc="A library handling all the details of proxy configuration"
+url="http://code.google.com/p/libproxy/"
+arch="all"
+license="LGPLv2+"
+depends=
+depends_dev=
+makedepends="cmake $depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-bin py-$pkgname:py"
+source="http://libproxy.googlecode.com/files/libproxy-$pkgver.tar.gz"
+
+_builddir="$srcdir"/libproxy-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIBEXEC_INSTALL_DIR=lib \
+ -DMODULE_INSTALL_DIR=/usr/lib/libproxy/$pkgver/modules \
+ -DWITH_PERL=OFF \
+ ./ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/cmake "$subpkgdir"/usr/share/
+}
+
+bin() {
+ pkgdesc="Binary to test libproxy"
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+py() {
+ pkgdesc="Binding for libproxy and python"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="199c6b120baf1f7258a55f38d5ec74f5 libproxy-0.4.6.tar.gz"