aboutsummaryrefslogtreecommitdiffstats
path: root/main/libpthread-stubs
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-01-25 16:43:57 +0000
commit9526ee659401dee7160f35cb62ded2779bcbbc99 (patch)
tree812ad73bde9c84dcc02a3acbc5db576369ca314a /main/libpthread-stubs
parent05e09c1126a898b6d0af491fef0401bf53e297f8 (diff)
downloadaports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.bz2
aports-9526ee659401dee7160f35cb62ded2779bcbbc99.tar.xz
merged x11 repository into main
ref #255
Diffstat (limited to 'main/libpthread-stubs')
-rw-r--r--main/libpthread-stubs/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/main/libpthread-stubs/APKBUILD b/main/libpthread-stubs/APKBUILD
new file mode 100644
index 0000000000..7ca630b435
--- /dev/null
+++ b/main/libpthread-stubs/APKBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libpthread-stubs
+pkgver=0.3
+pkgrel=0
+pkgdesc="Pthread functions stubs for platforms missing them"
+url="http://cgit.freedesktop.org/xcb/pthread-stubs"
+license="X11"
+depends=
+source="http://xcb.freedesktop.org/dist/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ ./configure --prefix=/usr
+ # we actually have pthread_exit, the configure script just
+ # fails to detect it
+ make CFLAGS="$CFLAGS -DHAVE_PTHREAD_EXIT=1"
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make -j1 DESTDIR="$pkgdir" install
+}
+md5sums="e8fa31b42e13f87e8f5a7a2b731db7ee libpthread-stubs-0.3.tar.bz2"