aboutsummaryrefslogtreecommitdiffstats
path: root/main/libraw1394
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-30 14:30:07 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-30 14:30:07 +0000
commitccbcc6c918cad57a3dc0fec1ca9cc051dc49a74c (patch)
tree3bbf757081f5468c5c4e472498656fd40d2878be /main/libraw1394
parentf6ee0e0b56a6685ae58a5458621b66d7962853be (diff)
downloadaports-ccbcc6c918cad57a3dc0fec1ca9cc051dc49a74c.tar.bz2
aports-ccbcc6c918cad57a3dc0fec1ca9cc051dc49a74c.tar.xz
main/libraw1394: fix musl build
Diffstat (limited to 'main/libraw1394')
-rw-r--r--main/libraw1394/APKBUILD15
-rw-r--r--main/libraw1394/fix-types.patch51
2 files changed, 61 insertions, 5 deletions
diff --git a/main/libraw1394/APKBUILD b/main/libraw1394/APKBUILD
index 55170c5f99..017556e4e5 100644
--- a/main/libraw1394/APKBUILD
+++ b/main/libraw1394/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=libraw1394
pkgver=2.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="Library to provide access to Linux 1394 subsystem"
url="http://sourceforge.net/projects/libraw1394"
arch="all"
@@ -11,7 +11,9 @@ depends_dev=
makedepends=""
install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="ftp://ftp.kernel.org/pub/linux/libs/ieee1394/$pkgname-$pkgver.tar.bz2"
+source="ftp://ftp.kernel.org/pub/linux/libs/ieee1394/$pkgname-$pkgver.tar.bz2
+ fix-types.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
@@ -52,6 +54,9 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-md5sums="2f8d06a826b658bd0f3f0697e930dd52 libraw1394-2.1.0.tar.bz2"
-sha256sums="81798ea6ce1c7f4eaf9d8970ee635f9ade7fd05735a82b291947814481af45df libraw1394-2.1.0.tar.bz2"
-sha512sums="01e38ae140fc672e82e2702f59530484dc08b3290c42089de48c43844f80584bcfac6d1cb86d47b22ac79b218efedfbb51a4bd2c229a461ec413c1161ea09330 libraw1394-2.1.0.tar.bz2"
+md5sums="2f8d06a826b658bd0f3f0697e930dd52 libraw1394-2.1.0.tar.bz2
+19638d27477be8be3102e2cc154ae553 fix-types.patch"
+sha256sums="81798ea6ce1c7f4eaf9d8970ee635f9ade7fd05735a82b291947814481af45df libraw1394-2.1.0.tar.bz2
+6b831c9fd2dbf62c37b27a3a8cc77edd62e1e6bad192344e3a3dc675ba41e351 fix-types.patch"
+sha512sums="01e38ae140fc672e82e2702f59530484dc08b3290c42089de48c43844f80584bcfac6d1cb86d47b22ac79b218efedfbb51a4bd2c229a461ec413c1161ea09330 libraw1394-2.1.0.tar.bz2
+2b9d6e0fe279f714ebd152205eb4a3b0f2beb38a07d1cc2867291df2f707edd91a9bcfa79ae5dfec06ce709bd733215e732401736d9d9178ce1bf3cbeeb325cd fix-types.patch"
diff --git a/main/libraw1394/fix-types.patch b/main/libraw1394/fix-types.patch
new file mode 100644
index 0000000000..34f27a0bc5
--- /dev/null
+++ b/main/libraw1394/fix-types.patch
@@ -0,0 +1,51 @@
+--- libraw1394-2.1.0.orig/src/fw-iso.c
++++ libraw1394-2.1.0/src/fw-iso.c
+@@ -303,7 +303,7 @@
+ }
+
+ static int handle_iso_event(raw1394handle_t handle,
+- struct epoll_closure *closure, __uint32_t events)
++ struct epoll_closure *closure, uint32_t events)
+ {
+ fw_handle_t fwhandle = handle->mode.fw;
+ struct fw_cdev_event_iso_interrupt *interrupt;
+--- libraw1394-2.1.0.orig/src/fw.c
++++ libraw1394-2.1.0/src/fw.c
+@@ -187,7 +187,7 @@
+
+ static int
+ handle_echo_pipe(raw1394handle_t handle,
+- struct epoll_closure *ec, __uint32_t events)
++ struct epoll_closure *ec, uint32_t events)
+ {
+ quadlet_t value;
+
+@@ -258,7 +258,7 @@
+
+ static int
+ handle_device_event(raw1394handle_t handle,
+- struct epoll_closure *ec, __uint32_t events)
++ struct epoll_closure *ec, uint32_t events)
+ {
+ fw_handle_t fwhandle = handle->mode.fw;
+ union fw_cdev_event *u;
+@@ -421,7 +421,7 @@
+
+ static int
+ handle_inotify(raw1394handle_t handle, struct epoll_closure *ec,
+- __uint32_t events)
++ uint32_t events)
+ {
+ fw_handle_t fwhandle = handle->mode.fw;
+ struct inotify_event *event;
+--- libraw1394-2.1.0.orig/src/fw.h
++++ libraw1394-2.1.0/src/fw.h
+@@ -48,7 +48,7 @@
+
+ struct epoll_closure {
+ int (*func)(raw1394handle_t handle,
+- struct epoll_closure *closure, __uint32_t events);
++ struct epoll_closure *closure, uint32_t events);
+ };
+
+ struct port {