aboutsummaryrefslogtreecommitdiffstats
path: root/main/librsync/APKBUILD
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2017-05-15 21:31:32 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-05-16 02:47:20 +0200
commitb4160ee227b2bcf4bc2ec726e6bfe8ba51f76626 (patch)
treed75476e20c98ecdab6c0aaf4e66a618ac06e521b /main/librsync/APKBUILD
parente5173496aee5e0114383d201385feec0acfed3dc (diff)
downloadaports-b4160ee227b2bcf4bc2ec726e6bfe8ba51f76626.tar.bz2
aports-b4160ee227b2bcf4bc2ec726e6bfe8ba51f76626.tar.xz
main/librsync: backport fix for segfault
When running rdiff-backup we get a segfault in librsync.so.2.0.0, backport upstream fix.
Diffstat (limited to 'main/librsync/APKBUILD')
-rw-r--r--main/librsync/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/main/librsync/APKBUILD b/main/librsync/APKBUILD
index 972f49a3a6..e7be9aaf1c 100644
--- a/main/librsync/APKBUILD
+++ b/main/librsync/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Jeremy Thomerson <jeremy@thomersonfamily.com>
pkgname=librsync
pkgver=2.0.0
-pkgrel=0
+pkgrel=1
pkgdesc="librsync implements the rolling-checksum algorithm of rsync"
url="https://github.com/librsync/librsync"
arch="all"
license="LGPL 2.1"
makedepends="cmake popt-dev bzip2-dev zlib-dev perl"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/librsync/librsync/archive/v$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/librsync/librsync/archive/v$pkgver.tar.gz
+ 0001-Handle-searched-checksum-is-bigger-than-any-existing.patch"
builddir="$srcdir"/$pkgname-$pkgver
build() {
@@ -25,4 +26,5 @@ package() {
install -D -m644 doc/librsync.3 "$pkgdir/usr/share/man/man3/librsync.3" || return 1
}
-sha512sums="1a88dcc3aa60949e058c57eb0df3e0086823c493de40fed927246f5aada6274db57202074456a0ce5d9aa8b81b41836b0d6221ded6a75d43829572584177e8c0 librsync-2.0.0.tar.gz"
+sha512sums="1a88dcc3aa60949e058c57eb0df3e0086823c493de40fed927246f5aada6274db57202074456a0ce5d9aa8b81b41836b0d6221ded6a75d43829572584177e8c0 librsync-2.0.0.tar.gz
+ca34d1b6d0c227d582926e4342711a17604ece50b99bc5657758b50b405bc6df216c3c47d5ddb055f47d45b67ef056aefbd9d58317921202b68fc4c31433bcc4 0001-Handle-searched-checksum-is-bigger-than-any-existing.patch"