aboutsummaryrefslogtreecommitdiffstats
path: root/main/libshout
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@gmail.com>2011-04-05 10:04:33 +0000
committerLeonardo Arena <rnalrd@gmail.com>2011-04-05 10:05:52 +0000
commitc394cda428562c0626bdc145912874fd42679948 (patch)
treed26e74be7d4c464e9f9e140635b0b9ecea043fa1 /main/libshout
parent29c163ccbcf427d0f5e93af3fbefc1fd94e75e03 (diff)
downloadaports-c394cda428562c0626bdc145912874fd42679948.tar.bz2
aports-c394cda428562c0626bdc145912874fd42679948.tar.xz
testing/libshout: move to main
Diffstat (limited to 'main/libshout')
-rw-r--r--main/libshout/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/main/libshout/APKBUILD b/main/libshout/APKBUILD
new file mode 100644
index 0000000000..8f0e1f69fd
--- /dev/null
+++ b/main/libshout/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=libshout
+pkgver=2.2.2
+pkgrel=0
+pkgdesc="Library for accessing a shoutcast/icecast server"
+url="http://www.icecast.org/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="speex-dev libtheora-dev libvorbis-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.xiph.org/releases/$pkgname/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ --sysconfdir=/etc
+ --localstatedir=/var
+ make LDFLAGS+=-lspeex || return 1
+
+}
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4f75fc9901c724b712c371c9a1e782d3 libshout-2.2.2.tar.gz"