aboutsummaryrefslogtreecommitdiffstats
path: root/main/libunwind
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-19 00:43:48 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-19 00:45:02 +0200
commit212affd9b79e2bc3e6447a82442803c065d2eb07 (patch)
tree1e4bfe6f141cc5723978de44d4a115e898987bd6 /main/libunwind
parent3588fcf750bb237875b20e0b648ac2965b2cd809 (diff)
downloadaports-212affd9b79e2bc3e6447a82442803c065d2eb07.tar.bz2
aports-212affd9b79e2bc3e6447a82442803c065d2eb07.tar.xz
main/libunwind: fix incorrect type of UNW_VERSION_MINOR
This breaks Julia build.
Diffstat (limited to 'main/libunwind')
-rw-r--r--main/libunwind/APKBUILD8
-rw-r--r--main/libunwind/fix-UNW_VERSION_MINOR.patch12
2 files changed, 17 insertions, 3 deletions
diff --git a/main/libunwind/APKBUILD b/main/libunwind/APKBUILD
index dda0083f84..42e48dcd92 100644
--- a/main/libunwind/APKBUILD
+++ b/main/libunwind/APKBUILD
@@ -3,7 +3,7 @@
pkgname=libunwind
pkgver=1.2.1
_pkgver=${pkgver/_/-}
-pkgrel=0
+pkgrel=1
pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program"
url="http://www.nongnu.org/libunwind/"
arch="all !s390x !x86 !ppc64le"
@@ -13,7 +13,8 @@ depends_dev="libexecinfo-dev"
makedepends="$depends_dev autoconf automake libtool linux-headers"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc"
source="http://download.savannah.gnu.org/releases/libunwind/libunwind-$_pkgver.tar.gz
- force-enable-man.patch"
+ force-enable-man.patch
+ fix-UNW_VERSION_MINOR.patch"
builddir="$srcdir/$pkgname-$_pkgver"
build() {
@@ -37,4 +38,5 @@ package() {
}
sha512sums="af7c280d2a963779a4a2711887618bc96383011e4e5d52e4085aa7fb351e55e357468f6ff85e66a216f1c6826538f498335a917a5970575c93be74c96316319b libunwind-1.2.1.tar.gz
-7c2b9f48b74464c8c27367bfb0ede317bfbc5fc392c0d1371a9a82ae518d3799c019f6e258ec2262c4117c6fb936c40b7cb9f2bfebddb3ea4efbbcbcc4268822 force-enable-man.patch"
+7c2b9f48b74464c8c27367bfb0ede317bfbc5fc392c0d1371a9a82ae518d3799c019f6e258ec2262c4117c6fb936c40b7cb9f2bfebddb3ea4efbbcbcc4268822 force-enable-man.patch
+6efc82cb6ab042da68f982789644896b1dd24d6232f5ffd911f9aedcb01439d6b794c0534b64ee7c39f1ea46fff563e980c6650291440365e577ea0b4abc3436 fix-UNW_VERSION_MINOR.patch"
diff --git a/main/libunwind/fix-UNW_VERSION_MINOR.patch b/main/libunwind/fix-UNW_VERSION_MINOR.patch
new file mode 100644
index 0000000000..3fd4c61946
--- /dev/null
+++ b/main/libunwind/fix-UNW_VERSION_MINOR.patch
@@ -0,0 +1,12 @@
+Upstream-Issue: https://github.com/libunwind/libunwind/issues/30
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,6 +1,6 @@
+ define(pkg_major, 1)
+-define(pkg_minor, 2.1)
+-define(pkg_extra, )
++define(pkg_minor, 2)
++define(pkg_extra, 1)
+ define(pkg_maintainer, libunwind-devel@nongnu.org)
+ define(mkvers, $1.$2$3)
+ dnl Process this file with autoconf to produce a configure script.