aboutsummaryrefslogtreecommitdiffstats
path: root/main/libunwind
diff options
context:
space:
mode:
authortmpfile <tmpfile@users.noreply.github.com>2017-06-18 17:07:58 -0300
committerTimo Teräs <timo.teras@iki.fi>2017-06-19 14:01:42 +0000
commite91d8df7d2c557042cc87542db77a72a401d5d22 (patch)
treea446fa4b0753f7cb4083f82b58459fa5d17b8b43 /main/libunwind
parent7d36778112d5cac9799a55f0d8910b61334ed43c (diff)
downloadaports-e91d8df7d2c557042cc87542db77a72a401d5d22.tar.bz2
aports-e91d8df7d2c557042cc87542db77a72a401d5d22.tar.xz
main/libunwind: upgrade to 1.2.1
Diffstat (limited to 'main/libunwind')
-rw-r--r--main/libunwind/APKBUILD25
-rw-r--r--main/libunwind/aarch64.patch48
2 files changed, 8 insertions, 65 deletions
diff --git a/main/libunwind/APKBUILD b/main/libunwind/APKBUILD
index 053bcac9a8..38a878f0f6 100644
--- a/main/libunwind/APKBUILD
+++ b/main/libunwind/APKBUILD
@@ -1,31 +1,24 @@
# Contributor: Ben Pye <ben@curlybracket.co.uk>
# Maintainer: Ben Pye <ben@curlybracket.co.uk>
pkgname=libunwind
-pkgver=1.2
+pkgver=1.2.1
_pkgver=${pkgver/_/-}
-pkgrel=2
+pkgrel=0
pkgdesc="Portable and efficient C programming interface (API) to determine the call-chain of a program"
url="http://www.nongnu.org/libunwind/"
-arch="x86_64 armhf aarch64"
+arch="all !s390x"
license="MIT"
depends=""
depends_dev="libexecinfo-dev"
makedepends="$depends_dev autoconf automake libtool linux-headers"
subpackages="$pkgname-dbg $pkgname-dev $pkgname-doc"
source="http://download.savannah.gnu.org/releases/libunwind/libunwind-$_pkgver.tar.gz
- aarch64.patch
force-enable-man.patch"
builddir="$srcdir/$pkgname-$_pkgver"
-prepare() {
- cd "$builddir"
- default_prepare || return 1
- update_config_sub || return 1
- autoreconf -f -i || return 1
-}
-
build() {
cd "$builddir"
+ autoreconf -f -i
LDFLAGS="-lexecinfo" ./configure \
--build=$CBUILD \
@@ -34,16 +27,14 @@ build() {
--sysconfdir=/etc \
--mandir=/usr/share/man \
--localstatedir=/var \
- --enable-cxx-exceptions \
- || return 1
- make || return 1
+ --enable-cxx-exceptions
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="985d0817944e3cafd99aaa5642862d878972e0851f7954289247e808c9319f399ca29342395f0571cb6568a1104a82bd92d585936f2ca888dda37ac796fde0d4 libunwind-1.2.tar.gz
-e65c1929e51237a993660d17b5e2206dc95a133ef847f070558c2b5011a0d38a232dd3a5683f4ed255d0cc6a55629be7517bd2a04f8b9515d3c0618fb5b47071 aarch64.patch
+sha512sums="af7c280d2a963779a4a2711887618bc96383011e4e5d52e4085aa7fb351e55e357468f6ff85e66a216f1c6826538f498335a917a5970575c93be74c96316319b libunwind-1.2.1.tar.gz
7c2b9f48b74464c8c27367bfb0ede317bfbc5fc392c0d1371a9a82ae518d3799c019f6e258ec2262c4117c6fb936c40b7cb9f2bfebddb3ea4efbbcbcc4268822 force-enable-man.patch"
diff --git a/main/libunwind/aarch64.patch b/main/libunwind/aarch64.patch
deleted file mode 100644
index 18b81c3eaf..0000000000
--- a/main/libunwind/aarch64.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From cf6382643efd133e617c2cf1dba7e53868ccd690 Mon Sep 17 00:00:00 2001
-From: Christopher Ferris <cferris@google.com>
-Date: Tue, 15 Apr 2014 11:12:03 -0700
-Subject: [PATCH] Add aarch64 getcontext functionality.
-
-Change-Id: I32912a85c0fd02bb5e45a9eb7deb2410ded352a9
----
- include/libunwind-aarch64.h | 27 +++++++++++++++++++++++++--
- 1 file changed, 25 insertions(+), 2 deletions(-)
-
-diff --git a/include/libunwind-aarch64.h b/include/libunwind-aarch64.h
-index cd01e57..fe9e83d 100644
---- a/include/libunwind-aarch64.h
-+++ b/include/libunwind-aarch64.h
-@@ -175,8 +175,31 @@ typedef ucontext_t unw_tdep_context_t;
- #include "libunwind-common.h"
- #include "libunwind-dynamic.h"
-
--#define unw_tdep_getcontext(uc) (getcontext (uc), 0)
--#define unw_tdep_is_fpreg UNW_ARCH_OBJ(is_fpreg)
-+#define unw_tdep_getcontext(uc) (({ \
-+ unw_tdep_context_t *unw_ctx = (uc); \
-+ register uint64_t *unw_base asm ("x0") = (uint64_t*) unw_ctx->uc_mcontext.regs; \
-+ __asm__ __volatile__ ( \
-+ "stp x0, x1, [%[base], #0]\n" \
-+ "stp x2, x3, [%[base], #16]\n" \
-+ "stp x4, x5, [%[base], #32]\n" \
-+ "stp x6, x7, [%[base], #48]\n" \
-+ "stp x8, x9, [%[base], #64]\n" \
-+ "stp x10, x11, [%[base], #80]\n" \
-+ "stp x12, x13, [%[base], #96]\n" \
-+ "stp x14, x13, [%[base], #112]\n" \
-+ "stp x16, x17, [%[base], #128]\n" \
-+ "stp x18, x19, [%[base], #144]\n" \
-+ "stp x20, x21, [%[base], #160]\n" \
-+ "stp x22, x23, [%[base], #176]\n" \
-+ "stp x24, x25, [%[base], #192]\n" \
-+ "stp x26, x27, [%[base], #208]\n" \
-+ "stp x28, x29, [%[base], #224]\n" \
-+ "str x30, [%[base], #240]\n" \
-+ "mov x1, sp\n" \
-+ "stp x1, x30, [%[base], #248]\n" \
-+ : [base] "+r" (unw_base) : : "x1", "memory"); \
-+ }), 0)
-+#define unw_tdep_is_fpreg UNW_ARCH_OBJ(is_fpreg)
-
- extern int unw_tdep_is_fpreg (int);
-