aboutsummaryrefslogtreecommitdiffstats
path: root/main/libva-glx/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-09 13:06:24 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-09 13:13:26 +0000
commitbca1f0caf3caccd95f6d4159b67f5e563e69b534 (patch)
treeffd7a40b755d81c9561d7ee5197d1c1e733e6f23 /main/libva-glx/APKBUILD
parent393b073735f2aaff2ebad7c070c0ddf489bc0568 (diff)
downloadaports-bca1f0caf3caccd95f6d4159b67f5e563e69b534.tar.bz2
aports-bca1f0caf3caccd95f6d4159b67f5e563e69b534.tar.xz
main/libva-glx: new package to solve circular dep with mesa
Diffstat (limited to 'main/libva-glx/APKBUILD')
-rw-r--r--main/libva-glx/APKBUILD63
1 files changed, 63 insertions, 0 deletions
diff --git a/main/libva-glx/APKBUILD b/main/libva-glx/APKBUILD
new file mode 100644
index 0000000000..98ef61ef9c
--- /dev/null
+++ b/main/libva-glx/APKBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+
+# this package is to resolve the circular dependency libva -> mesa -> libva
+
+pkgname=libva-glx
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Video Acceleration (VA) API for Linux with MESA support"
+url="http://freedesktop.org/wiki/Software/vaapi"
+arch="all"
+options="!check" # No test suite.
+license="MIT"
+depends=""
+depends_dev="libva-dev mesa-dev"
+makedepends="$depends_dev autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev"
+source="https://github.com/01org/libva/releases/download/${pkgver}/libva-${pkgver}.tar.bz2"
+builddir="$srcdir"/libva-$pkgver
+
+prepare() {
+ ( if [ -f "$startdir"/../libva/APKBUILD ]; then
+ _v=$pkgver
+ . "$startdir"/../libva/APKBUILD
+ if [ "$_v" != "$pkgver" ]; then
+ die "libva and libva-glx needs to be same version"
+ fi
+ fi )
+
+ cd "$builddir"
+ default_prepare
+ # we need to regen the configure script which will unconditionally
+ # depend on wayland scanner otherwise
+ libtoolize --force && aclocal -I m4 && autoconf \
+ && automake --add-missing
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-x11 \
+ --enable-glx \
+ --disable-drm \
+ --disable-wayland \
+ --disable-static \
+ --enable-shared
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -type f -o -type l \) \! -name '*glx*' -delete
+}
+
+sha512sums="973b32117375f81ad0ebb8b9f8d5516fd115a9eb9ac95cf9a0e10ee7d340d8d9e41f3e7aa79a2c85f2736f2bc206abbb57a59998cf69019616788e6a571bf24b libva-2.1.0.tar.bz2"