aboutsummaryrefslogtreecommitdiffstats
path: root/main/libva
diff options
context:
space:
mode:
authorA. Wilcox <AWilcox@Wilcox-Tech.com>2018-02-11 00:04:07 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-17 13:39:46 +0000
commit1ed613f34f618667d90240d72e435766a9f88f6f (patch)
tree4eb53b67c6e732415d0ece072fa06d880d7cb590 /main/libva
parent71c9b7566d831e6a16d7a44df06a940800b270e5 (diff)
downloadaports-1ed613f34f618667d90240d72e435766a9f88f6f.tar.bz2
aports-1ed613f34f618667d90240d72e435766a9f88f6f.tar.xz
main/libva: modernise, mark no tests
Diffstat (limited to 'main/libva')
-rw-r--r--main/libva/APKBUILD22
1 files changed, 8 insertions, 14 deletions
diff --git a/main/libva/APKBUILD b/main/libva/APKBUILD
index f5c76b3722..42713b5c7d 100644
--- a/main/libva/APKBUILD
+++ b/main/libva/APKBUILD
@@ -6,6 +6,7 @@ pkgrel=0
pkgdesc="Video Acceleration (VA) API for Linux"
url="http://freedesktop.org/wiki/Software/vaapi"
arch="all"
+options="!check" # No test suite.
license="MIT"
depends=""
depends_dev="mesa-dev"
@@ -14,15 +15,9 @@ install=""
subpackages="$pkgname-dev"
source="https://github.com/01org/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
-_builddir="$srcdir"/${pkgname}-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ cd "$builddir"
+ default_prepare
# we need to regen the configure script which will unconditionally
# depend on wayland scanner otherwise
libtoolize --force && aclocal -I m4 && autoconf \
@@ -30,7 +25,7 @@ prepare() {
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,14 +37,13 @@ build() {
--enable-x11 \
--disable-wayland \
--disable-static \
- --enable-shared \
- || return 1
- make || return 1
+ --enable-shared
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="72e0aba7808d541c4d54c2628c372d765e444bcdd266b9ef7a1aec2c9c8732efda6fb525befbf39ba2f8f3c845c2d647bef6678875d7b78fa2db5eaa05442bf3 libva-2.0.0.tar.bz2"