aboutsummaryrefslogtreecommitdiffstats
path: root/main/libva
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-05-09 13:14:56 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-05-09 13:14:56 +0000
commite751b0fc452fd9b7a7b146ae55b89ca1dfa451f5 (patch)
tree7b5793e5b1a363e4de43d5b908dd80387ec20d60 /main/libva
parentbca1f0caf3caccd95f6d4159b67f5e563e69b534 (diff)
downloadaports-e751b0fc452fd9b7a7b146ae55b89ca1dfa451f5.tar.bz2
aports-e751b0fc452fd9b7a7b146ae55b89ca1dfa451f5.tar.xz
main/libva: check that version corresponds with libva-glx
Diffstat (limited to 'main/libva')
-rw-r--r--main/libva/APKBUILD7
1 files changed, 7 insertions, 0 deletions
diff --git a/main/libva/APKBUILD b/main/libva/APKBUILD
index 49ef2689ad..b2b1f09feb 100644
--- a/main/libva/APKBUILD
+++ b/main/libva/APKBUILD
@@ -16,6 +16,13 @@ subpackages="$pkgname-dev"
source="https://github.com/01org/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.bz2"
prepare() {
+ ( if [ -f "$startdir"/../libva-glx/APKBUILD ]; then
+ _v=$pkgver
+ . "$startdir"/../libva-glx/APKBUILD
+ if [ "$_v" != "$pkgver" ]; then
+ die "libva and libva-glx needs to be same version"
+ fi
+ fi )
cd "$builddir"
default_prepare
# we need to regen the configure script which will unconditionally