aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxml2
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-06-17 13:55:46 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-06-17 14:23:18 +0200
commit16f791e8f3f64b809c45d74db815e57f035477af (patch)
treead33485b54bbde791a2f7b5d2b6038873129986b /main/libxml2
parent3893cbbcd57fd5c167925bbc2a368972da251486 (diff)
downloadaports-16f791e8f3f64b809c45d74db815e57f035477af.tar.bz2
aports-16f791e8f3f64b809c45d74db815e57f035477af.tar.xz
main/libxml2: upgrade to 2.9.8, switch to http:// source
Diffstat (limited to 'main/libxml2')
-rw-r--r--main/libxml2/APKBUILD17
-rw-r--r--main/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch12
2 files changed, 9 insertions, 20 deletions
diff --git a/main/libxml2/APKBUILD b/main/libxml2/APKBUILD
index 210994e358..cfca80feeb 100644
--- a/main/libxml2/APKBUILD
+++ b/main/libxml2/APKBUILD
@@ -1,22 +1,19 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=libxml2
-pkgver=2.9.7
-pkgrel=1
+pkgver=2.9.8
+pkgrel=0
pkgdesc="XML parsing library, version 2"
url="http://www.xmlsoft.org/"
arch="all"
license="MIT"
-depends=
depends_dev="zlib-dev"
checkdepends="perl tar"
makedepends="$depends_dev python2-dev python3-dev"
subpackages="$pkgname-dbg $pkgname-doc $pkgname-dev $pkgname-utils
py-$pkgname:_py py2-$pkgname:_py py3-$pkgname:_py"
options="!strip"
-source="ftp://ftp.xmlsoft.org/${pkgname}/${pkgname}-${pkgver}.tar.gz
- libxml2-2.9.4-remove-pyverify_fd.patch
- "
+source="http://xmlsoft.org/sources/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
# secfixes:
@@ -29,8 +26,13 @@ builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
+
# setup.py is generated
rm python/setup.py
+
+ # We don't build libxml2 with icu.
+ rm test/icu_parse_test.xml
+
cp -ra "$builddir" "$builddir"-python2
}
@@ -99,5 +101,4 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="da06cb7c5032ef4b7c8e902fabb9d2c74634c42c161be07a7c66a00d53a68029f89b0d4de32a6b9d4ff338c2d1d9c4e53aefb9cf50cb1c2d6c6b06b442ef42d5 libxml2-2.9.7.tar.gz
-271e701daf08f10a8b591c5128f596105901a29ecc9ee72f088afab266eaec7932a4a7d2194baa07c69e1aa93f3e9dc01a4a890456f53416c45d490598be41d9 libxml2-2.9.4-remove-pyverify_fd.patch"
+sha512sums="28903282c7672206effa1362fd564cbe4cf5be44264b083a7d14e383f73bccd1b81bcafb5f4f2f56f5e7e05914c660e27668c9ce91b1b9f256ef5358d55ba917 libxml2-2.9.8.tar.gz"
diff --git a/main/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch b/main/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch
deleted file mode 100644
index d05d4cb60f..0000000000
--- a/main/libxml2/libxml2-2.9.4-remove-pyverify_fd.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nur libxml2-2.9.4.orig/python/types.c libxml2-2.9.4/python/types.c
---- libxml2-2.9.4.orig/python/types.c 2016-02-09 03:17:33.000000000 -0700
-+++ libxml2-2.9.4/python/types.c 2016-12-21 12:34:06.755650986 -0700
-@@ -31,8 +31,6 @@
- const char *mode;
-
- fd = PyObject_AsFileDescriptor(f);
-- if (!_PyVerify_fd(fd))
-- return(NULL);
- /*
- * Get the flags on the fd to understand how it was opened
- */