aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-05-24 11:15:53 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-05-24 11:15:53 +0000
commit062d5f16167921bd66297d12b2cd85d79fb0943e (patch)
tree3b96ca980a7be335fe5e42798cebda89ee3c8bc9 /main/libxp
parente6d9eccdf7eeb94ed8fdd2cd4e7ebd51ed7fb04a (diff)
downloadaports-062d5f16167921bd66297d12b2cd85d79fb0943e.tar.bz2
aports-062d5f16167921bd66297d12b2cd85d79fb0943e.tar.xz
main/libxp: build fix for 64bit
Diffstat (limited to 'main/libxp')
-rw-r--r--main/libxp/0001-Stop-trying-to-use-NULL-for-Status-values.patch50
-rw-r--r--main/libxp/APKBUILD6
2 files changed, 55 insertions, 1 deletions
diff --git a/main/libxp/0001-Stop-trying-to-use-NULL-for-Status-values.patch b/main/libxp/0001-Stop-trying-to-use-NULL-for-Status-values.patch
new file mode 100644
index 0000000000..d8c6057f4c
--- /dev/null
+++ b/main/libxp/0001-Stop-trying-to-use-NULL-for-Status-values.patch
@@ -0,0 +1,50 @@
+From 776e739b1690c7de11e50e2ae2a77d98bd69a3d6 Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Wed, 23 May 2012 21:48:59 -0700
+Subject: [PATCH] Stop trying to use NULL for Status values
+
+Fixes gcc errors in 64-bit builds:
+XpNotifyPdm.c: In function 'XpGetPdmStartParams':
+XpNotifyPdm.c:234:10: error: cast from pointer to integer of different size
+XpNotifyPdm.c:271:10: error: cast from pointer to integer of different size
+XpNotifyPdm.c:286:10: error: cast from pointer to integer of different size
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+---
+ src/XpNotifyPdm.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/XpNotifyPdm.c b/src/XpNotifyPdm.c
+index c1ceb8e..579923c 100644
+--- a/src/XpNotifyPdm.c
++++ b/src/XpNotifyPdm.c
+@@ -231,7 +231,7 @@ XpGetPdmStartParams (
+ /*
+ * Error - cannot determine or establish a selection_display.
+ */
+- return( (Status) NULL );
++ return( (Status) 0 );
+ }
+
+ /*
+@@ -268,7 +268,7 @@ XpGetPdmStartParams (
+ XCloseDisplay( *selection_display );
+ *selection_display = (Display *) NULL;
+ }
+- return( (Status) NULL );
++ return( (Status) 0 );
+ }
+
+ status = XmbTextListToTextProperty( *selection_display, list, 6,
+@@ -283,7 +283,7 @@ XpGetPdmStartParams (
+ XCloseDisplay( *selection_display );
+ *selection_display = (Display *) NULL;
+ }
+- return( (Status) NULL );
++ return( (Status) 0 );
+ }
+
+ *type = text_prop.encoding;
+--
+1.8.2.3
+
diff --git a/main/libxp/APKBUILD b/main/libxp/APKBUILD
index 4bd21ace04..fe6d5c49b4 100644
--- a/main/libxp/APKBUILD
+++ b/main/libxp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libxp
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="X.Org X11 libXp runtime library"
url="http://www.x.org"
arch="all"
@@ -13,6 +13,7 @@ makedepends="$depends_dev libtool autoconf automake util-macros"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://xorg.freedesktop.org/releases/individual/lib/libXp-$pkgver.tar.bz2
+ 0001-Stop-trying-to-use-NULL-for-Status-values.patch
0001-Replace-deprecated-Automake-INCLUDES-variable-with-A.patch
0002-Use-_XEatDataWords-to-avoid-overflow-of-rep.length-b.patch
0003-integer-overflow-in-XpGetAttributes-XpGetOneAttribut.patch
@@ -51,18 +52,21 @@ package() {
}
md5sums="7ae1d63748e79086bd51a633da1ff1a9 libXp-1.0.1.tar.bz2
+b52d9e1211abece91ce91b96cbeec7da 0001-Stop-trying-to-use-NULL-for-Status-values.patch
dfc36d7aa39348115edbed43e7b3bacd 0001-Replace-deprecated-Automake-INCLUDES-variable-with-A.patch
8d99d975ee248d292c57f0539a74f444 0002-Use-_XEatDataWords-to-avoid-overflow-of-rep.length-b.patch
0affd2550812541d7c6e03b10a882a39 0003-integer-overflow-in-XpGetAttributes-XpGetOneAttribut.patch
74e9e315a2b7b714c2ebbc69e4478723 0004-integer-overflows-in-XpGetPrinterList-CVE-2013-2062-.patch
59085b08c7ae142238ee20af93836926 0005-integer-overflows-in-XpQueryScreens-CVE-2013-2062-3-.patch"
sha256sums="71d1f260005616d646b8c8788365f2b7d93911dac57bb53b65753d9f9e6443d2 libXp-1.0.1.tar.bz2
+6cd5d7b70861a35434f87c8494755ee125945b9bfb6189314c94edcf806aa104 0001-Stop-trying-to-use-NULL-for-Status-values.patch
666273216e13b759e85cf84c345e9253771e729f605987e580ad55b0ad7651a3 0001-Replace-deprecated-Automake-INCLUDES-variable-with-A.patch
f128151ebd1206d85c6ee55d1558fb1e3f446a7334466571818850096fec7a87 0002-Use-_XEatDataWords-to-avoid-overflow-of-rep.length-b.patch
ad96f0031978dd8befa29bde872a8a9b40e4fbfccf42cd22e201f975564db3b6 0003-integer-overflow-in-XpGetAttributes-XpGetOneAttribut.patch
cbadbece5e73d568826b19b2f743860c8dfe47f4077accffa939cc51a79ead0c 0004-integer-overflows-in-XpGetPrinterList-CVE-2013-2062-.patch
0a597afeab8bd76dcd72fec97efd0a8db12c1dd1d9f431085e061aa1b6ca1f3d 0005-integer-overflows-in-XpQueryScreens-CVE-2013-2062-3-.patch"
sha512sums="0707256ae344b847f1a5bbf85f9e6e6f926be3bee10858e3c92932ee02007fdb908cb64a6f2ce0de501f99117e4582c1bcf9bc6f921490d42cabbfb997d731bd libXp-1.0.1.tar.bz2
+ac9c215a03b6408c72bcd017d4059f09bc7e0345a90ee79a29476534316c57057a9ada717af4f3ec511cf19c57f4e98bee05856b8cbb6c14b83e1bf9349797f9 0001-Stop-trying-to-use-NULL-for-Status-values.patch
5a55658cedbf6ac8d410f19ceed0ef38d65a81ef54e9ffde86ac285c477669d760a1b5c2d9791aff50d48698298bcfdd3290e1b95321c62230809a8a65222127 0001-Replace-deprecated-Automake-INCLUDES-variable-with-A.patch
9a94b99f96d03e436450daa40e54d3d091d362e76428a4bc0fdacb38b3582c1a18ad5b1824621282892bc3f9e0964bae2d8e15ccdfc5c27a426f118c7a7336c8 0002-Use-_XEatDataWords-to-avoid-overflow-of-rep.length-b.patch
48d47a8878f2f3663c1e00091c6190ae9d4b0e08594cfb87d4810e726caf5a138100ef59d0fdb352cb5805ab3268bedde86f20d4637533f81d71451fc0989f20 0003-integer-overflow-in-XpGetAttributes-XpGetOneAttribut.patch