aboutsummaryrefslogtreecommitdiffstats
path: root/main/libxshmfence
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-04-21 06:55:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-04-21 07:33:36 +0000
commit471c5b10dd5e917a068b172f0d05839c3603b9d7 (patch)
treeb3936cc0dc51a338c76df10cf5a6501fdebc47cc /main/libxshmfence
parent4951d733b2fc0a1a578ad3655700adc98350ab4d (diff)
downloadaports-471c5b10dd5e917a068b172f0d05839c3603b9d7.tar.bz2
aports-471c5b10dd5e917a068b172f0d05839c3603b9d7.tar.xz
main/xshmfence: new aport
X11 shared memory fences http://www.x.org/ Needed by mesa-10.1
Diffstat (limited to 'main/libxshmfence')
-rw-r--r--main/libxshmfence/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/main/libxshmfence/APKBUILD b/main/libxshmfence/APKBUILD
new file mode 100644
index 0000000000..0fdf12b439
--- /dev/null
+++ b/main/libxshmfence/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer:
+pkgname=libxshmfence
+pkgver=1.1
+pkgrel=0
+pkgdesc="X11 shared memory fences"
+url="http://www.x.org/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev="xproto"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://xorg.freedesktop.org/releases/individual/lib/libxshmfence-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/libxshmfence-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="2dd10448c1166e71a176206a8dfabe6d libxshmfence-1.1.tar.bz2"
+sha256sums="dbc2db2925ca9f216fd1e9c63d0974db9f4d49aaf5877ffb606d2d8d7e58cebe libxshmfence-1.1.tar.bz2"
+sha512sums="ed3aae4a44849c11ce041df53d47667606dba5357059c13d5c0989205df57dfa626598db6ad66432114a80e69ab4118fb067877ea275897aab64d4bbf9bcd346 libxshmfence-1.1.tar.bz2"